An email server was detected, however your credentials were rejected

Hi, I’m using eM Client version 7.1.32088.0 and Alibaba enterprise email service.
When I setup my account manually, SMTP is working while IMAP part is not. eM Client keeps showing Password Required for New Account. And after click Fix and a few rounds trying by the application, such information is displayed finally ‘An email server was detected, however your credentials were rejected’.
I’m 100% sure the username and password are correct. Furthermore, I also can use the same account to sign in to the email through the web interface, as well as in another email client application (Foxmail). There’s no 2-steps authentication enabled either.
So, what shall I proceed from here?

You need to check that your IMAP settings are correct in Menu > Tools > Accounts. I see that Alibaba recommend port 143 so make sure you have that.

Port: 143
Security policy: Use SSL/TLS if available

Another option is

Port: 993
Security policy: Use SSL/TLS on special port (legacy)

Thanks for the reply Gary. I will try it later and get back to you on the result.

Hi Gary, I tried both port 143 and 993 with corresponding security policies. But it always showing a pop-up window ‘Server says failed’

btw, the server domain is not alibaba according to its web email FAQ. It’s

OK, your domain is hosted by Alibaba, that is why it is different. Sorry.

Do you have your full email address as the username, or just the part before the @?

I have full email address as the username and it’s working in web interface and other email client application such as Foxmail and Windows 10 built-in mail.

Did you try to remove the account from eM Client, then add it again?

Did you try with Automatic Setup?

Yes, Gary. I tried remove/add the account in eM Client and also try uninstall/install it again multiple times. As well as using automatic setup at first two times.

What are the settings you have in Foxmail?

Host, port, security.

Hi Gary, Thanks for your reply… actually I think I’m using same settings in both Foxmail and eM Client.

For port 993, you need to ensure that the security policy is: Use SSL/TLS on special port (legacy).

Another option would be your anti-virus or firewall, so if you can completely disable that and try again.

The only other thing I can think is that the server may have blocked eM Client because of too many failed login attempts.

Thanks for your suggestions. I did use SSL/TLS on special port (legacy) as security policy in eM Client.
That’s failed either after disable firewall/anti-virus.
I guess that you were right on the server may have blocked requests from eM Client.
Let me try to contact with email service provider.
Thanks a lot!