Always Can't Connect to Server

Always can’t connect to the mail server, client show as below,
Error

But the mail can receive after some try.

The mail server is provided by 263 which is a famous commercial mailbox service provider in China. Using eM Client always warning Connection failed, but no error when using other client like Outlook or Foxmail. The log of eM Client is as bellow:

17:35:22 Work IMAP Synchronizing folder ‘/Sent’
17:35:22 Work IMAP Synchronizing folder ‘/Sent’
17:35:23 Work [IMAP] MailClient.Accounts.ConnectionException: Lost connection with server
—> MailClient.Imap.Base.ConnectionLostException: Lost connection with server
at MailClient.Imap.Base.Extensions.<>c__DisplayClass30_0.<g__SlowAsyncPath|1>d.MoveNext()
— End of stack trace from previous location —
at MailClient.Imap.Base.Connection.ReceiveAsync()
— End of inner exception stack trace —
at MailClient.Protocols.Imap.ImapActionCommand.ExecuteInternalSync(WorkerStatus status)
at MailClient.Protocols.Imap.ImapActionCommand.Execute(WorkerStatus status)
at MailClient.Commands.Command.Process(WorkerStatus status)
— End of stack trace from previous location —
at MailClient.Protocols.Imap.ImapAccount.<>c__DisplayClass106_0.<b__0>d.MoveNext()
— End of stack trace from previous location —
at MailClient.Protocols.Imap.ImapAccount.SynchronizeIntAsync(Boolean forced)
at MailClient.Protocols.Common.SynchronizableMailAccount.<>c__DisplayClass6_0.<b__0>d.MoveNext()
EnqueuedStackTrace =
at MailClient.Protocols.Common.ItemSynchronizer2.<>c__DisplayClass37_1.<EnqueueSynchronize>g__RunSynchronize|2() at MailClient.Protocols.Common.ItemSynchronizer2.<>c__DisplayClass37_0.b__0()
at MailClient.Protocols.Common.AccountBase.RunIfOnline(Action actionIfOnline, Action actionIfOffline)
at MailClient.Protocols.Common.ItemSynchronizer2.EnqueueSynchronize(Folder folder, Boolean fast, CancellationToken cancellationToken, Action1 completed)
at MailClient.Protocols.Common.ItemSynchronizer2.MailClient.Storage.Synchronization.IItemSynchronizer<TStorageItem>.Synchronize(Folder folder, SynchronizationPriority priority, Action1 completed)
at MailClient.Storage.Application.ItemCollection2.Synchronize(SynchronizationPriority priority, Action1 completed)
at MailClient.Storage.Application.Folder.Synchronize(SynchronizationPriority priority)
at MailClient.Protocols.Imap.ImapFolderSynchronizer.FolderActivated(Folder folder, Boolean goingOnline)
at MailClient.Protocols.Common.FolderSynchronizer.MailClient.Storage.Synchronization.IFolderSynchronizer.Activate(Folder folder)
at MailClient.Storage.Application.Folder.Activate()
at MailClient.Storage.Application.ItemCollection2.Activate() at MailClient.Protocols.Imap.ImapAccount.<>c__DisplayClass106_0.<<SynchronizeIntAsync>b__0>d.MoveNext() at System.Runtime.CompilerServices.AsyncMethodBuilderCore.Start[TStateMachine](TStateMachine& stateMachine) at MailClient.Protocols.Imap.ImapAccount.<>c__DisplayClass106_0.<SynchronizeIntAsync>b__0() at System.Threading.Tasks.Task1.InnerInvoke()
at System.Threading.Tasks.Task.<>c.<.cctor>b__277_0(Object obj)
at System.Threading.ExecutionContext.RunFromThreadPoolDispatchLoop(Thread threadPoolThread, ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot, Thread threadPoolThread)
at System.Threading.Tasks.Task.ExecuteEntryUnsafe(Thread threadPoolThread)
at System.Threading.Tasks.Task.ExecuteFromThreadPool(Thread threadPoolThread)
at System.Threading.ThreadPoolWorkQueue.Dispatch()
at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()
GUIStatus_Exception_Reported = True

As the error says you lost connection with the server, it may be that something is interrupting the connection.

As a test, can you completely disable any anti-virus, firewall, proxy or VPN, then try again.

The problem is still existed after I disable anti-virus and firewall, not using proxy and VPN in my PC. I also had tried re-add mail account before. The connection interrupted looks like only happened in same situation, because I try three times by click “Send and Receive All”, The log looks like all same, just like what I sent before.