All my accounts disappeared after factory reset; client won't stay open

My Mac (running MacOS Monterey v12.6.3) had a major meltdown after I tried to upgrade to Ventura (v. 13). It had to be cleaned by pros, and everything had to be reinstalled from TimeMachine. When I started eM Client for the first time all of the accounts and all of the emails were missing. The program starts up and the window appears, but it never finds anything to populate the windows with. The “I’m working on it” icon just goes around and around indefinitely. I can add an account, but it doesn’t find the old emails. I am still getting all my emails on my other computer and on my phone, so the data are out there. I have uninstalled and re-installed eM Client, but that did not help. If I exit and re-open it, it shuts itself down very quickly; I’m not sure why or when it stops getting stuck in looking mode and switches to won’t-stay-open mode, but I think a computer restart puts it back into looking mode. I’ve tried to re-install from a different backup and got this:

MailClient.Storage.Data.DatabaseHasNewerVersionException: Data file '/Users/Dany/Library/Application Support/eM Client//folders.dat' has version 8 but only versions up to 3 are supported
  at MailClient.Storage.Data.DbRepository`1[T].ThrowIfNewerVersionThanSupported (System.Int32 dbVersion, System.String databaseName, System.String resourceName) [0x00051] in <47b68c3ae04a49528b6ee1d78ccd0fdb>:0 
  at MailClient.Storage.Data.DbRepository`1[T].CheckSchema (System.String databaseName, System.String resourceName) [0x00008] in <47b68c3ae04a49528b6ee1d78ccd0fdb>:0 
  at MailClient.Storage.Data.DbRepository`1[T]..ctor (MailClient.Storage.Data.DataStore dataStore, System.String location, System.String indexTable, System.String[] readWriteDatabaseNames, System.String[] readOnlyDatabaseNames) [0x0012e] in <47b68c3ae04a49528b6ee1d78ccd0fdb>:0 
  at MailClient.Storage.Data.DbRepository`1[T]..ctor (MailClient.Storage.Data.DataStore dataStore, System.String location, System.String indexTable, System.String[] readWriteDatabaseNames) [0x00000] in <47b68c3ae04a49528b6ee1d78ccd0fdb>:0 
  at MailClient.Storage.Data.DbFolderRepository..ctor (MailClient.Storage.Data.DataStore dataStore, System.String dbLocation) [0x00000] in <63888f53656248e1b9b6afbb133a1177>:0 
  at MailClient.Accounts.ItemRepositories.Open (MailClient.Storage.Data.DataStore dataStore, System.String accountPath, MailClient.Accounts.AccountType accountType) [0x00000] in <d784cf40960742b49c262f0845763915>:0 
  at MailClient.Accounts.ItemRepositories..ctor (MailClient.Storage.Data.DataStore dataStore, System.String accountPath, MailClient.Accounts.AccountType accountType, System.String accountName, System.String protocolName) [0x0021f] in <d784cf40960742b49c262f0845763915>:0 
  at MailClient.DbRepair.ConsistencyChecker.CheckConsistencyForAccount (System.String accountDirectory, MailClient.Storage.Data.RepairMode mode, System.Threading.CancellationToken token) [0x00062] in <3296fe349d4c43558676c1dff0326e2b>:0 
  at MailClient.DbRepair.ConsistencyChecker+<>c__DisplayClass2_0.<Check>b__0 (System.String p) [0x00000] in <3296fe349d4c43558676c1dff0326e2b>:0 
  at MailClient.DbRepair.PerAccountExecutor.Execute (System.String dataStoreLocation, System.Func`2[T,TResult] action) [0x0002a] in <3296fe349d4c43558676c1dff0326e2b>:0 
  at MailClient.DbRepair.ConsistencyChecker.Check (MailClient.Storage.Data.RepairMode mode, System.Threading.CancellationToken token) [0x00026] in <3296fe349d4c43558676c1dff0326e2b>:0 
  at MailClient.DbRepair.CheckingProcess.Check (System.Threading.CancellationToken token) [0x0006b] in <3296fe349d4c43558676c1dff0326e2b>:0 
Data:
AccountType: Mail
DatabaseLocation: /Users/Dany/Library/Application Support/eM Client/Archive

Anybody have any idea how to fix this? Thank you

miércoles 08 marzo 2023 :: 0841hrs (UTC +0100)

I am not familiar with Macbook time Machine other than I know it is a backup function.
However, I guess the issue will be “at what point was the backup made?”.
As you had a disaster with your upgrade maybe there is a clue here.
I suggest that you download eMC direct from here:

choosing the version you want, installing and proceeding from there with an eMC
backup, assuming you have one.

Unless a Mac specialist knows better.

¡Buena suerte!

skybat

¡Saludos desde Valencia la soleada en España!

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

The error is actually because you have installed an older version of eM Client than what was used when the backup was made. Install the latest release from the Release History and it should be fine.

Also, please note that you can’t use Time Machine to reliably backup eM Client databases for two reasons:

  1. External backup options will not backup open files, so if eM Client is running when the backup happens, due to the way SQL database work, you may end up with an empty backup.

  2. You can’t make incremental or differential backups of the database which is what Time Machine does. You need a snapshot of ALL of the files and folders made at one time. Unfortunately you can’t backup and later restore just some files from a backup into the database and hope it will work. In most cases it won’t. It may break the database and the data will be lost.

eM Client has its own backup option, which you can run manually, or set to run on a schedule. Please use that to ensure your data is safe.

1 Like

Hola, gracias. time machine copies everything, including the eM Client backups. After I downloaded and installed the newest version of eM Client (from the eM Client website as you suggest), I attempted to restore eM client using the last definitely-correct backup. So it is not the version of eM Client.

Hi Gary. Each time I tried, I downloaded the most recent version from the eM client website. Also, I didn’t use TimeMachine to back up eM Client, TimeMachine to backs up everything, including the zipped eM Client Backups in the eM Client backup folder. I tried to restore it from the recreated eM Clioent backup folder. That did not work. Next, in case going through TimeMachine and back out messes up the eM Client backup file, I also tried restoring using an eM Client backup from my other computer, so, no TimeMachine involved. That did not work either. Finally, if I just re-create the accounts, nothing appears. Anything new stays there, but nothing on the server appears, no folders, no mail in the inbox, nothing. It’s really strange.