Aliases & Replies/Forwards

If aliases are set up for an account, then the appropriate alias should automatically be pre-selected when one replies to an e-mail or forwards it.

Additionally, I believe that there is no need to add the Reply-To flag to e-mail headers should an alias be selected while composing a message.

EXAMPLE:

eM Client Account:
account@gmail.com; also aggregates messages from second@hotmail.com and third@yahoo.com

Aliases set up in eM Client for account@gmail.com:
second@hotmail.com, third@yahoo.com

When replying to or forwarding an e-mail sent to second@hotmail.com (but retrieved from the aggregated mailbox account@gmail.com!), the appropriate alias (second@hotmail.com) should be pre-selected in the e-mail compose window upon clicking the Reply/Forward button. Analogously, for e-mails sent to third@yahoo.com (but – again – retrieved from account@gmail.com), third@yahoo.com should be pre-selected in the From combo box.

In both the above cases, eM Client adds the Reply-To flag to the e-mail header, which, IMHO, is redundant, since it only repeats the data from the From flag (i.e., the identity information).

If one is replying to or forwarding an e-mail message sent to an address for which no appropriate alias exists, then the account’s default identity should be pre-selected (current behaviour for all replies).

I have tested it right now and the Aliases are chosen for Reply-to properly - can you please tell me what version of eM CLient are you using?

I tested it in the latest version, i.e., 5.0.17595.0. Anyway, I carried out a few more tests to confirm my suspicion and I think I know what is the cause of the problem.

If one enters aliases solely as e-mail addresses, everything works fine, but the sent messages are from ‘john@doe.com’, not from ‘John Doe <john@doe.com>’. If a full alias is entered into settings (e.g. ‘Jose <jose@server.com>’ or ‘=?UTF-8?Q?Jos=C3=A9?= <jose@server.com>’ should an accented name be required), then the default identity is always pre-selected in the From combobox. (I can only speculate that it might be for example due to matching of entire aliases with the respective e-mail address…)

The aliases were always just email addresses and not full names. Entering a full name will not work and it generates invalid messages and possibly errors on the SMTP server. We are tracking it as a feature request to allow setting custom names in the aliases, but currently that’s not possible.

For information, an alias with a full name does correctly send mails if the alias is defined in the form “myemail@mydomain.com (Full Name)” rather than "Full Name ", but the logic to preselect the from address when replying and forwarding doesn’t account for it.

I made a request just over a year ago to have this feature added and mentioned that the pattern matching would need to use a regex to match the start of the alias string, and not the whole thing.

Go on - fix it - you know you want to :wink:

If any of you would also like to see the “delayed send” feature added to emClient, please vote for Delayed Send here:
https://discourse.emclient.com/emclient/to…