Aliases not visible

I set up two alias accounts, but when I try to compose an email, the alias email accounts are not visible in the dropdown window. What am I doing wrong.

First, click the arrow to select accounts.

Next, click the arrow next to the account who the aliases belong to.

domingo 12 junio 2022 :: 1805hrs (UTC +01:00)

Hey @videone

I presume you were able to add the alias email addresses into your account.
1/. Did you click OK? - obvious that you need to do this
2/. Did you also click ‘Save & Close’? - a common mistake to miss this
3/. As @Gary indicates you should see your available address at #2 if you have done as above

¡Buena suerte!

¡Saludos desde la soleada Sevilla en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

1 Like

Skybat, that was it. I didn’t click “Save & Close”. Duh. Thanks.

Another question…when I send an email out using an alias in the ‘from’ box it displays the name I gave the alias and my email address. Is there a way to display only the alias email address?

domingo 12 junio 2022 :: 2132hrs (UTC +01:00)

Hey @videone

Pleased that it was a simple fix.

Name display…
This will happen if the alias address is not registered with your ISP as
a separate entity.
If you own your own domain name this may not be an issue.
It may be that your ISP will allow several email addresses on your account
without charge; you will need to check with them.

¡Buena suerte!

¡Saludos desde la soleada Sevilla en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

The alias address I’m using is registered. It’s a Gmail address.

lunes 13 junio 2022 :: 0855hrs (UTC +01:00)

Hey @videone

I have just setup an alias on 2 accounts that I have with no issue, with only
the alias sender address being shown when sent to a different address on a
different domain.
I can not help with Gmail/Google as I do not have an account to check.
Perhaps someone else with Gmail/Google will see your post to help you.
You should also check with Gmail/Google direct.
Also as an alternative you could setup separate accounts in eMC using
the alias address/es if you have a Pro account as the number of accounts
you have is not restricted, of course if you have a Free account you are
limited to 2 accounts.
My email address at the bottom of this post is an alias with a separate
rule populated mail box.

¡Buena suerte!

¡Saludos desde la soleada Sevilla en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

I setup a dummy alias email address jsmith@icloud.com using the eM Client support documentation link above hanging off my personal Gmail address in eM Client V9 and it appeared ok on the popout menu in the compose window.

I’ve also setup alias email addresses in eM Client on a friend’s Google Workspace Business domain account and it worked exactly the same.

If you want to set an alias email address as the default from Gmail to match eM Client, go online to your Gmail account, and click “See all settings” at the top right. Then click “Accounts and Import” and you will see a section called “Send mail as” near the bottom where you can add whatever alias email address you want as the default for sending mail, and then click “Make Default” on the right.

Then when you send email from eM Client the recipient will see the Gmail alias email address as the default reply address.