After the last update from eMC Office files do not open

Yesterday I´ve upgraded the eMC to the latest version 9.2.1777 (0fcc8f6). I use the eMC Pro version for MAC.
Since the mentioned update, whenever I click on a word, excel or powerpoint file attached in an email, the Office window opens but the document is not shown.
The only solution is to download the file to the MAC and open from the saved file. It is not practical for someone like me who receives hundreds of emails in a day. :frowning:
I thought it might be an Office issue, but when doing the same action with Outlook everything runs smoothly, the attached files are shown.
Interestingly if the attached files are pdfs there is no problem.
How can this problem be solved? Is there any way to install an old eMC version? I´ve tried but it won’t let me… it says I have the latest version and the installer won’t run anymore.
Any help is appreciated. I do not want to get back to Outlook because i love work with eMC but this problem is really severe and affects my productivity.
Regards to all.

As eM Client opens files using the user profile temp folder, could be you may need to "clear the cache in your user profile. On a Mac that’s usually via the Menu “Go / Folder / Library / Cached”. There will be an eM Client folder in there. Open that folder and delete everything in there. Then reopen eM Client and try again.

Note: Before clearing the eM Client cache folder, backup eM Client via the “Menu / Backup” option via the drop-down along the top on the Mac.

Thanks for the reply.
Unfortunately in my MAC I can’t find the folder “cached” in order to delete it… I´m using macOS Monterey (Last version). I don´t know if the the folder could be in other part of the system…
Any idea?
Thank´s in advance.

To clear an Application cache on Monterey and Ventura using the Finder / Command line.

Open a “Finder window” and then press “Shift-Command-G” to open the Go to Folder window.

Type ~/Library/Caches in the blank box as in the example screenshot below. Then click the Go button, and you will see the caches of all applications.


Next “find the eM Client folder” and “open it”.

Then lastly “delete all its files in there” and then “reopen eM Client” and see if that fixes it.

Note: As I said previously backup eM Client first via the drop-down menu, and then close eM Client before clearing the folder cache.

Hi Cyberzork,
I have followed the mentioned procedure, but unfortunately the problem persists. It looks like I will have to switch to Microsoft Outlook :unamused:
I really like eMC but not opening Office files means that I lose a lot of work time saving it to MAC and open manually.
Thanks for your help and if you have any other ideas I’d appreciate it.

How are you opening the attachment? Are you double-clicking on it, or are you opening it from Mac’s QuickLook, so from the Open button in the thumbnail preview?

When you save such an attachment and then change it’s permissions from read-write to read-only, would it open when double-clicked? To change permissions, right-click the file in the Finder window and choose “Get Info”. Permissions can be set at the bottom of the window.