Address Autocomplete Shows Old Addresses

When I’m composing an e-mail, I will start to type the recipient’s name in the To: field, and eM Client gives suggestions.

Expected/Desired Behavior: I want it to show only the addresses in my Contacts list.

Observed Behavior: It shows addresses from Contacts, but also old (no longer valid) addresses that are in old e-mails.

What I’ve Done: I went to Menu/Settings/Mail/Compose and cleared the Recipients History, then verified that the history actually is empty, and also verified that the Store composed mail recipients for suggestion box is not checked. The issue persists.

I’m on Windows 10 and using a GMail account.

Is there something else I can/should do?

Sounds like you may not have clicked SAVE and CLOSE in the settings after “Menu/Settings/Mail/Compose”.

sunriseal,

Thanks for responding! I went back in and verified that all of those settings are as intended, so apparently I had saved them. In any case, I was careful to save again, then re-checked and the issue persists.

What version of eMC are you using?

I’m at 8.2.1659 (845a639) and it says no update is available.

v9.x has been out for a while and can be accessed here.

Might be worth considering upgrading.

If not, then perhaps you may want to uninstall v8 and reinstall v8. If so, then ask for instructions if you need some guidance.

Strange that I was 4 or 5 versions behind and it still said that no update was available. But I updated manually and there’s no change. I’ll try uninstall/reinstall and see what happens.

When you start typing an address in the To field, the one that is suggested may have a X on the extreme right of the suggestion. If it does, that is in the Recipients History and you can click on the X to delete it. If it doesn’t have an X, it is in your Contacts, maybe another account or in Local Folders.

2 Likes

Gary, I’m not seeing the X by the invalid address. I can’t locate any contacts list anywhere in eMC or elsewhere on my system, other than the GMail contacts that I normally use and that does not contain the “bad” address. I’ve also verified that it is not just picking up addresses from old e-mails. (I started typing the address of some people who sent me mail but who are not in my contacts. It didn’t pick that up.) Really stumped here. Very strange.

Go to Menu > Settings > General > General and select Show Local Folders.

Go to the contacts section of eM Client. In the search box, click the down arrow and make sure All Folders are selected. Type in the invalid address and hit Enter.

This will find the contact for you.

Gary, thank you so much! That did it! I would never have found that on my own.

The Local folder had two sub-folders: “My Contacts” and one named with my e-mail address (that is, my GMail account). The contents were very odd. They contained dozens of entries, but I can’t make sense of them. They included:

  • Entries that are in my real contacts list and are correct
  • Entries that are in my contacts, but with outdated information
  • Entries with info that was never correct and I’m sure were never like that in my real contacts
  • Entries that I had deleted years ago
  • About a dozen entries that were listed as “No Name” and were completely blank

And yet it excluded entries that have always been in my contacts (e.g. my wife and one of my sons), so it’s not just an old backup or something.

Just curious–any idea where this came from?

1 Like

It is possible that at some point you imported these from another application, or copied then from the synced Gmail contacts you had in eM Client at the time.

The Local Folder items are not synced with servers, so any changes you made elsewhere, would not have updated those.

I guess. Nothing quite fits, but I suppose an import could have been corrupted.

Anyway, the important thing is that the problem is solved. Thanks again!