Adding security key for two steps authentications causing a crash

Hello everybody,

First of all, this is my first day here and my English is not my first language so please don’t angry if i accidentally post it in the wrong group or explained myself incorrectly - let me know and i will fix it as soon as possible.

So the issue happened while i tried to add any kind of security key (i have about 4 different types - all of them are brand new and I’m using them on a daily base) so after I’m plugging in the security key the whole PC is just freezing and a window popped up saying “Something went wrong. The Request timed out” (even though i’m doing it very quickly).
I’m using Windows 10 64 Bit, with updated drivers, with Chrome (even though the issue happens the same on Edge). I already tried different USB ports to eliminate that the issue is in my laptop.zy
Link to the video or the screenshot of the issue (sorry it is not from a screen recorder, i was too lazy to download one).

I would highly appreciate it if you have any clue what happens or how to solve this issue.

Thank you in advance.

Firstly, does this have anything to do with eM Client? What you have described above seems to be Windows issues as you have not once mentioned eM Client.

Secondly, please don’t use links to sites that require registration or other security credentials to access the screenshots. Just paste them here. The video you can’t paste here, but the screenshots you can.

Finally, eM Client can’t use a USB encryption key; only soft keys like PGP encryption pairs.

Sorry for the misunderstanding - as said my English is not the best so please try to understand.

As far I understand they are talking about Hardware Security Keys so I don’t understand what PGP encryption you are talking about.
Second thing - this is an external website and not the eM Client.
Please see the screenshot.

Unfortunately eM Client does not support hardware keys.

Again, this is NOT for the client. I am talking about the registration for the website:
And it’s clearly says HARDWARE SECURITY KEYS.
Please let me know what i’m missing here?

This forum is provided by Discourse so you could look for assistance on the Discourse Forum.

Maybe this thread will be a good place to start: