Account setup with Google 2 step verification

What has to be done to add a Google account that has 2 step verification on? I can add my gmail accounts that do not have 2 step verification on but cannot add wither of my gmail accounts that have 2 step verification turned on. I get an " Invalid certification error"
What do i need to do to correct this?

After you create the account, a popup requiring password should appear - can you confirm that? Can you eventually re-create the account? It should work without any problems.

I’m trying setup an Google account with 2-step verification but I’m getting an error. How can I fix it?

What error are you getting? Could you please be more specific? Or send a screenshot of the error message?

It’s an authentication error. I’m not prompted for the application specific password.

Did you try to enter the specific password in the pop up window asking for password?

There was no popup for application specific password

Can you please post here a screenshot of the popup window?

Hi George
It seems like 2-step authentication is not really supported any longer? - I am asked for password every 30 days which is really annoying.
Once the account has been set up it shouldn’t keep asking about password

Hello Mikkel,
we did not remove support for 2-step verification.
Do you have an application password setup for eM Client?


But where or how to type it in EM Client? When creating the Google account in EM Client you are taking through the process and it only accept your password and the 2-step verification code generated by the APP.
It will not accept the application password.
Also it is not possible to edit the password after setup.

Please provide me a guide for how to do this

Hello Mikkel,
try removing the gmail account from the Tools>Accounts window.
Set up the account again as a new account.
Use the application password INSTEAD of your usual password for login.


I have of course already tried this. The problem is that it does not accept the application password.
It rejects the application password.

I have no issues in other tools

Hello Mikkel,
this a very curious issue, especially since you can set up the Google account with your regular password just fine.
Are you sure the password prompt was for this account?
Have you perhaps just removed eM Client’s access in google security settings?

You cannot edit the password after setup because Gmail setup uses the oAuth window where you allow the access through your web browser, eM Client does not store your Gmail password.

Is there any problem with the synchronization at this time?
If so can you copy the error messages/prompt window/etc?


I have not removed EM Client access, but if you know where I should check, then I can try to see

If you use the oAuth setup - will you then be asked every 30 days if you have 2-step turned on? - because that is what is happening for me now.

Right now it is working but just annoying to have to authenticate every 30 days.

Hello Mikkel,
as I said, you should NOT be asked for the password again once you Allow the access through oAuth.
Please keep the setup as is now and when you are prompted for the password again, please go to Menu>Tools>Settings>Advanced and click ’ Send logs’.
Change the recipient of these logs to me ([email protected]) and ideally add a link to this forum thread (so I know which issue this log is tied to).
The oAuth logs are made automatically so hopefully we will be able to tell what the issue is.
Thank you.