Account missing on the list, can't log in

I had this issue for a long time, kinda learned to live with it, but recently it become more annoying, hence looking for some help here…

I have an email account on server Some years ago, eMClient (currently 7.2.50008.0) was connecting to this account via POP3, but that stopped working. Some time later they switched to IMAP, I’ve set up the account again in emclient, but:

  1. it doesn’t show on the list of accounts on the left hand side of the main screen. I have several accounts (gmail, yahoo, other servers) linked, only this one doesn’t show up.

  2. emclient is trying to connect to the server, the login and password are fine (checked several times), but it can’t. A window pops up with my login details (so I could type in the password etc) with a message “Servers says “Failed””. I can only click ok, which does nothing, the window pops up again, or cancel. The is no other error message, the error list is empty. The log only mentions, that I’ve aborted log in, after choosing “cancel”, see below:
    23:21:28 MailClient.Accounts.AuthenticationAbortedException: Authentication aborted
    23:21:28 at MailClient.Protocols.Imap.ConnectionPoolEntry.Reconnect(CancellationToken cancellationToken)
    23:21:28 at MailClient.Protocols.Imap.ConnectionPoolEntry.Connect(CancellationToken cancellationToken)
    23:21:28 at MailClient.Protocols.Imap.ConnectionPool.AcquireConnection(Folder mailFolder, Boolean idle, Boolean forStore)
    23:21:28 at MailClient.Protocols.Imap.ConnectionContext…ctor(ImapAccount account)
    23:21:28 at MailClient.Protocols.Imap.Synchronizer.SynchronizeFoldersCommand.ExecuteInternal(WorkerStatus status)
    23:21:28 at MailClient.Protocols.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status)
    23:21:28 at MailClient.Commands.Command.Process(WorkerStatus status)

In the log file on the drive I found only this, in relation to this particular account:
23:01:20.968|01A| ReacquireCredentials[*](IMAP, Failed.)
23:01:27.263|01A| ReacquireCredentials[](IMAP, Failed.) = false

I tried:

  • removing and re-adding the account (many, many times, including the POP3, just in case - NOTE: none of them show up on the main screen)
  • reinstalling emclient
  • trying the same on a new computer
  • Diagnostics-> Fix (for both IMAP and SMTP, as they both failed) - “An email was detected, however your credentials were rejected. Do you want to try again using a different password or username?”. As mentioned, the credentials are correct. Using the same credentials on their webpage logs me in with no issues. The server address and ports are also fine (checked on their website)

Any ideas?

Thanks Kar7

EDIT: Win10 Home->Win11 Home, no additional antivir or firewall, also tried with/without VPN

The account won’t be added to the list because the credentials you provided are incorrect.

Check you are using the full email address for the username, and maybe reset the password on the webmail page. Also check if you are required to use an app password (sometimes called a security key) rather than the account password.

If you are absolutely sure the credentials are correct, then you will need to contact the email provider, because their server is not accepting the ones you entered.

Thaks for the response. Already tried resetting password, credentials are 100% fine. Their ( setup info page doesn’t mention any app password.

But why wouldn’t it show up on the list of the accounts? This doesn’t make sense, say I change a password in one of my email account, emclient doesn’t recognize the credentials, so the account would dissappear? I don’t think so… I’d be just asked to provide a new password. Plus, when it first stopped working years ago, the account was still visible, but had some red mark next to it, indicating, that there was an error with the conection/verification.

Because the credentials you entered are not accepted by the server, so the account won’t connect. It won’t be able to display anything until it connects to the server for the first time, and gets the list of folders from the server.

You will need to contact your email provider, because it is their server that is rejecting the credentials you have entered.

Thanks for the explanation Gary. Yeah, I’ll try to contact them, but that’s a free mailbox, so I don’t expect they’ll respond. Anyway, I appreciate your help.

martes 07 noviembre 2023 :: 0936hrs (UTC +0100)

A while back we had a client with a similar issue on, I do not remember
the answer to to the issue but I d know that it was resolved by their support page.
So definitely worth contacting them.



¡Los mejores desde Valencia y mantente a salvo!

[email protected]

Hablo español, luego portugués, inglés, francés y alemán
con conocimiento de varios otros idiomas.

Thanks for the encouragement, they have indeed responded with a solution:). Turns out there’s an option buried deep within account parameters “do you use an email client: yes/no”… Yeah:].