2-Factor GMX.net with app specific password "Authentification failed"

Hey :slight_smile:

I have a weird problem with my GMX.net account and eM Client.

My problem:
Everytime I start eM Client, I get the following error message from the GMX.net Account with a prompt to enter the password:

Server says "authentification failed"

I will give in the app specific password I created in the GMX.net online portal, because my 2-Factor is activated.
And it will run like a charm… till the next eM Client start.
Then I will get the error message again.
My workaround, use a second app specific password, that is NOT the first app specific password. And it works.
Till the next start, then I have to change the password back to the first app specific password… and so on.
I have to change from password 1 to 2 and back. With every restart.

Please help! That’s not very conviniend and a really strange problem :confused:

More info:

  • IMAP is working fine on mobile phone, too, with a third app specific password
  • I used the automatic setup for GMX and didn’t change anything there

The app password and 2FA are not the same thing. Please disable 2FA on the GMX account, then try again.

If I deactivate the 2 factor, then everything works with my account password.
But it’s not an option for me to deactivate this.

Didn’t you need the app specific passwords for clients, that can’t eat 2-Factor, or did I get something wrong?
And you only can create those, if 2-Factor is activated. After deactivating the 2-Factor, all my app specific passwords were gone and didn’t work either anymore.

We do not support 2FA with GMX. Sorry.

You can still use app passwords though, if you set that up.

Oh! After redoing 2-Factor and App specific password, I get following error message Server says "401". If I click on cancel, I will get emails, tho.

We do not support 2FA with GMX. Sorry.
You can still use the app password though, if you have set that up.

That’s the problem, the app specific password doesn’t work. I still get the error message, but mails are working fine.

Thanks for your help! I’m a little confused right now.

Yes, I just found this on their website: “Two-factor authentication must be activated to use application-specific passwords.”

So you can’t use either, apologies.

You will need to disable 2FA, and use the account password.

You will need to disable 2FA, and use the account password.

That’s a bummer. Thanks for the help :slight_smile:.

The only thing I don’t understand, I can send and receive mails with 2-Factor and app specific password. I only have to “cancel” away the error message window. Confusing.
Will write a little programm then to close those error messages as soon as they pop up :laughing:

1 Like

It may be a flaw on the server.

We do not support 2FA with GMX, because it is dependent on the account using oAuth, which we don’t support with them.

Oh, thanks for explanation, then I will take advantage of their flaw. :slight_smile:.
Thanks for the patience!