Yosemite Server 4 eM Client calendar connect issue

Can anyone connect to their calendar on a server running Yosemite Server 4?  eM Client worked find under Mavricks Server  3.1.2 .

Hi Andrew, are you seeing any errors while trying to connect to the server? Are you using the automatic or the manual setup in eM Client?
What version of eM Client are you currently using on your computer, can you please check for the exact version number in Help > About?

Thank you,
Paul.

I am also having issues connecting to OS X Server 4.
Using eM client 6.0.21040.0
I am using the manual setup which worked with OS X server 3.x
All I get is a password required popup and Server says “Unauthorized”.
All the eM log says is “internal server error”.
Other programs and devices have no issues connecting.

Hi Doug, what version of eM Client are you currently using on your computer? There should be no issues regarding OS X server connections, however if you’re seeing the “internal server error” error message, this points to a server issue on the OS X server. Can you please check for the exact version number in Help > About?
When the error occurs, can you please switch to the “Log” tab, copy the content of the log and post it here on the forum?

Thank you,
Paul.

Using eM client 6.0.21040.

10:14:33 AM Online state: changed to online with reason NetworkAvailability 10:15:22 AM doug [CalDAV / CardDAV]  Synchronizing subfolders: For folder doug/
10:15:22 AM doug [CalDAV / CardDAV]  MailExceptions.OperationException: Subfolder synchronization for folder “doug” failed with following error: Internal Server Error
10:15:22 AM doug [CalDAV / CardDAV]  Synchronizing subfolders: Done

If I set up the account with the actual folder location

[https://xxxxx.xxx:8443/principals/__uids__/6CC1412F-1BAD-4AD0-862E-B81D7CCA273D/](https://xxxxx.xxx:8443/principals/ uids /6CC1412F-1BAD-4AD0-862E-B81D7CCA273D/ “Link httpsrbcreindlbinderycom8443principals__uids__6CC1412F-1BAD-4AD0-862E-B81D7CCA273D”)
I just get the perpetual password required popup box. Username and password are correct but it keeps popping up like the password is incorrect.

Hi again Doug, can you please download this tool: http://www.telerik.com/download/fiddler , install the application, open it and navigate to Tools > Fiddler Options > HTTPs, check the option “Decrypt HTTPS connections” and enable logging/capturing traffic.

After you do so, please try to setup the account in eM Client, if the issue reoccurs, please navigate back to Fiddler and select “File > Save As > All Sessions”, and save the captured traffic into a .saz file.

Please repeat the same for the second issue (setting up the account using a folder location).

After you do so, please submit both archives to my email mcgregor@emclient.com with a reference link to this forum topic…

Regards,
Paul.

Hello,

I’ve just installed a Yosemite Server 4 and I’m migrating from Thunderbird to emClient at the same time.
I’m having the very same issue.
I can provide the logs you request (except for folder location because I don’t know it).
I can also provide the server logs for the connection attempts.

Would that help? I can do it quickly.
I’m very motivated because it causes quite some burden to have that issue.

Regards,

Nicolas

Hi, can you please try to update your application to this release and check if the issue persists, http://www.emclient.com/dist/v6.0.21129/setup.msi ?

Thank you,
Paul.

Hi Paul,

For me and with my Os x Server 4.0 are working this versión V6.0.21129.

Good Job.

Lluís

Excellent, it works for me as well!!!

Thanx a lot!

Nicolas

Great, glad it works please let us know if you come across any other issues or questions about the application, we’ll be happy to help.

Regards,
Paul

Hi Paul, I am still having issues connecting to OS X Server 4. After installing version V6.0.21129 there are no changes, with V6.0.21151.0 I still have the problem.
“Die Unterordner … konnten nicht synchronisiert werden: Service Unavailable”
“Die Unterordner … konnten nicht synchronisiert werden: Forbidden”
With Server 3 it worked fine, but after the update …
I use SSL, Windows 7 and/or 8.1 and tried several versions of the calendar-URL.
In Safari or Chrome one URL works (https://server.de/wiki/projects/groupname/calendar/), I can load the shared calendar from a wiki-group, but the previous working URL (https://server.de:8443/calendars/__uids__/wiki-groupname/calendar/) failed: “Service Unavailable. Wiki ACL lookup failed.” I checked the ACLs, no result.
On an other machine with the previous version of eM Client I get the message “Unauthorized”.
E-Mails are OK.

Axel

Hi again Axel, can you please try to setup the account again in eM Client and check if the issue persists after the account setup?
In case it does, please navigate to Tools > Settings > Advanced and turn on CalDAV logging for the problematic account,

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    If the problem persists, please navigate back to the advanced settings window and click on “Send logs” and submit the logs to my email mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul

I deleted all accounts (mail und caldav), removed and installed new eM Client, configured mail and caldav: the issue persists. I tried several urls for the calendar, but the problem still exists.
So I’ve send you the logs. 
Regards
Axel

During my tests with several configurtions I’ve found that eMClient works with calendars of “real” users ([https://server.de/principals/__uids__/73A1C242-9D03-44C8-8906-A4AFD4C0609E/](https://server.de/principals/ uids /73A1C242-9D03-44C8-8906-A4AFD4C0609E/ “Link httpsverwaltunggesamtschule-hardtdeprincipals__uids__73A1C242-9D03-44C8-8906-A4AFD4C0609E”)). This means, that the shared calendar of User1 could be displayed in eM Client if User1 logs in. If User1 shared in the calendar app of Mac OS X (Client or Server) his own calendar with User2 (Einstellungen - Accounts - Stellvertretung - Bearbeiten…), User2 can log in in eM Client and can use the calendar. - (Because I can’t use groups for sharing in this way, I use the wiki-calendar.)

But this is completly unattached from the settings of the wiki-calendar of User1. The address https://server.de/wiki/projects/lehrer1/calendar is full accessible in a browser (Win7/8 and Mac OS X), not in eM Client. In the calendar app in Mac OS X the address [https://server.de:8443/calendars/__uids__/wiki-lehrer1/calendar/](https://server.de:8443/calendars/ uids /wiki-lehrer1/calendar/ “Link httpsverwaltunggesamtschule-hardtde8443calendars__uids__wiki-lehrer1calendar”) is accessible and the credentials of the wiki-settings are working. In eM Client I get the message “service unavailable”.

Tested URLs:
[https://server.de:8443/calendars/__uids__/wiki-lehrer1/calendar/](https://server.de:8443/calendars/ uids /wiki-lehrer1/calendar/ “Link httpsverwaltunggesamtschule-hardtde8443calendars__uids__wiki-lehrer1calendar”)
https://server.de/wiki/projects/lehrer1/calendar
[https://server.de/principals/__uids__/73A1C242-9D03-44C8-8906-A4AFD4C0609E/](https://server.de/principals/ uids /73A1C242-9D03-44C8-8906-A4AFD4C0609E/ “Link httpsverwaltunggesamtschule-hardtdeprincipals__uids__73A1C242-9D03-44C8-8906-A4AFD4C0609E”)
https://server.de/principals/users/kalenderuser/

All these URLs are accessible with calendar app or browser in Mac OS X.

In Thunderbird I have the same problems! It seems, that apple changed something in the background. (In Thunderbird I missed the question for the credentials, no warnings came up.)