Yet Another emClient Stopped Working

About three weeks ago, every time I refresh I get Connection Failed message. Client has been in use for eight months, nothing has changed in the target account. IMAP & STMP tests say no problems and target account receives test message.

“3 weeks ago”?? Still happening? Only when refreshing, never when eMC retrieves during normal cycle (every 1 minute, 5 minutes, 20 minutes, etc)
Who is the email host?
Emc version?
Windows or Mac?
Imap or POP3?
Contacted Email host support?
Tried stopping VPN and Anti-virus apps?

The more info the better …

Earthlink webmail interface working properly
Yes - Tried stopping VPN and Anti-virus apps - NO CHANGE
Also checked for current certificates
Just downloaded install msi and ran REPAIR action - FAILED: "Missing a file in CAB fil311F0D19E7D5FEAF103D6A908A1909AA.
Fail is on any refresh action - manual or automatic.
This forum will not let me paste the Log File in this reply.

What did you attempt to download and from where?

All the time? Which would mean you never have been able to retrieve mail?

Have you tried removing the Imap account and re-adding? After doing an eMC backup (Menu > Backup)