Yahoo contacts not syncing ?

I have added my yahoo account to emClient. Just using the calendar and contacts for now. The calendar works great once I added the username/password manually, but the contacts does not sync and keeps popping up the username/password dialog. I looked at the settings and they seem ok except the Default folders box whch is greyed out, and displays nothing. If I try to Select a folder, I see a Local Folders shown but if I select this or create a folder I get message The fodler you seelcted doesn;t belong to this CALDAV account or isn;t a contact folder ?
Any ideas what is wrong ?

Hi Tony, what version of eM Client are you currently using?
Are you receiving any errors from the application?

Can you make a screenshot of your contacts settings from Tools > Accounts > Your account > Contacts.

Thank you,
Paul.

I’m using 6.0.20648.0

  1. The only problem is the contacts are not updating ever, and I get regular dialogs asking for username and password for the account I’m using. Here is screenshot, but I’ve removed a few sensitive bits.
    Thanks

Hi, please try to update to this version of eM Client http://www.emclient.com/dist/v6.0.20715/setup.msi , and change the Address (CardDAV URL) to:
https://carddav.address.yahoo.com

Hope this helps,
Paul.

Hi,
I upgraded to that version. And changed the CardDAv URL to https://carddav.address.yahoo.com as requested. The error is different. Now I do not see lots of dialog asking for login details, but I get after a while Operations dialog come up showing An error occurred. [CardDav] Subfolder synchronisation for foler “blah blah@yahoo.co.uk” failed with following error : Bad Request

Can you please make a screenshot of the error and when it occurs switch to the Log/History tab and copy the content of the log displayed?

Thank you,
Paul.

This is the error

This is the log window

This was with the carddav url changes as you suggested.

Can you please go to Tools > Settings > Advanced and turn on CardDAV logging for the problematic account?

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    When the error occurs, can you please go back to the advanced settings window and click on “Send logs” and send the logs to mcgregor@emclient.com with a reference link to this forum topic?

Also just to make sure, this error only displays for the CardDAV service and not Calendars (CalDAV) or any other services, right?

Thank you,
Paul.

I will. Yahoo email and calendar seem to be working fine, it is just carddav that fails strangely !

Hi again, can you please try to change the Calendar/Contacts settings to use “identity credentials” instead of “these credentials:”.

Hope this helps,
Paul.

Hi, no change in problem. Bad Request returned.
I did revert back to original url that eMClient initially suggested, and set use “identity credentials”, and I still get username/password dialog coming up repeatedly !
Regards

Hi again Tony, unfortunately this seems to be a temporary Yahoo issue, that we’re currently not able to respond to.
I’m afraid I can not provide a solution for this problem, and thus an only available suggestion would be disabling the CardDav service to get rid of the error.

I hope this will be resolved soon, but as I mentioned this is a Yahoo issue.

Thank you for understanding,
Paul.