Why do I not have an "Outbox"?

I just set up my eM Client because microsoft and gmail do not like each other. I set my account as I used to have in Outlook but I now do not have an “Outbox” field indicating there are messages to be sent.
Why is that, and how can I fix it?

Enable showing of Smart folders in Tools - Settings - General.