Why did eM ask to start a new account??

I just opened eM Client - which I have been using for about a year - and it made me establish a new account!!! Huh? Even after doing so, and setting the correct storage location on my computer, it does NOT show any of my folders, so I cannot access any stored emails. How can I access them??

If eM Client starts with an empty database and prompts you to setup an email account, that means the database has been removed from the computer.

What did you delete? 

Did you upgrade Windows? 

Do you have your most recent eM Client backup?

I deleted nothing. I did not upgrade Windows. And where would I find the most recent backup?

That depends on where you specified the backups to be saved, but by default on Windows they will be in an eM Client folder in your Documents.

All you need to do is go to Menu > File > Restore and it will select the most recent one for you.

Tried it; got an error, the text of which I copied/pasted and emailed to eM support. Would it help if I sent it here?

Not really but it probably does say something about why it could not restore. Post it here and let’s see.

Here it is:

System.IO.FileNotFoundException: Could not find file ‘F:\eM email client\backup_202001051835.zip’.
File name: ‘F:\eM email client\backup_202001051835.zip’
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileInfo.get_Length()
   at DbBackup.FormBackup.Restore(String backupFile, CancellationToken cancellationToken)
   at DbBackup.FormBackup.Restore(CancellationToken cancellationToken)
   at DbBackup.FormBackup.<>c__DisplayClass28_0.<mainform_load>b__0(Object a, DoWorkEventArgs b)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)


There was a thread just recently where the user could not restore from a USB drive, but when the zip file was copied to the Documents folder it worked.

Copy the latest zip file from the F: location to C:\Users\yourusername\Documents\eM Client\ and do the restore again. See if that works.

Thanks for your continued help. I am still on Windows 7, and there is no directory  *C:\Users\yourusername\Documents\eM Client* The closest is  C:\Users\yourusername_My Documents_ but there is no eM Clients subdirectory there.

Yes, older OS versions named it somewhat differently. I always wondered why they called it My Documents and not just Documents. Not really any need for the pronoun. At least the Redmond guys seem to have now come to their senses. :wink:

So, create a folder in your My Document s folder (see how stupid that sounds) and call it eM Client. Copy the zip file from your F: drive to that folder then in eM Client use Menu > File > Restore.

Seems to have done the trick… thanks so much!!\