when restarting the computer and opening em client a very long database check always emerges

when i turn off my computer and restart it there is a problem with em client

the programm alsways has some database issue (“checking database”) which it eventually solves, but this takes some minutes

I think the reason is that I activated the option “show em client in task bar” - so when I turn off the computer, windows must think that em client is still open - like it has not been closed before shutting down

how can I resolve this issue? (I do not want to turn off the taskbar option)

As a test, if you turn off the taskbar option, does it make any difference?

yes, before I activated this it did not happen

but I dont want to deactivate this option 

What version of eM Client are you using?

I know there were past issues with shutdown, but this was apparently improved somewhere in 7.2.3x

Also, if you are interested to try the beta version, you can download it from the Release History. Maybe it has been corrected there.

I will try Beta - thanks

I really like the reductionism and usablity of em client, so no, but thanks

trying to install beta - seeing this since about 15 minutes - what is going on?

It seems this is the same issue you were having with version 7. It should start quite quickly as the beta was much improved in this area.

As a test, close eM Client. You may have to use Windows Task Manager to close all instances of the application, then rename the C:\Users\yourusername\AppData\Roaming\eM Client\ directory to something else. You may have to enable hidden items in Windows Explorer to get there. Restart eM Client. That will start with a blank database. See if there is any difference in startup speed.

Some things that can slow down the database start are if you have the database stored on an old mechanical hard disk. Especially those slow RPM disks are a big issue for databases. Best is to have the database on an SSD. Another issue is an extremely large database, or a database stored on a USB or network share.

Otherwise for issues with the beta versions, please send feedback to testing@emclient.com.

now it worked, thanks a lot

since I use IMAP everything was downloaded from the server

next I importet the setting file - superb

lets wait and see if the other problems have vanished

Yeah, this is a good approach because you start with a blank database, so any possible problems with the previous files are discounted.

AFAIK the problem has to do with the circumstance that eM Client needs a certain (quite long) amount of time after closing the window until it is really shut down. When you turn off the PC while em Client is still performing undisclosed database operations, that inevitably leads to a lengthy database check (depending on the size of your database) the next time you start it. That has always been the case and with the new beta I experience the same thing, when I am too eager to turn off my PC.

Pefunk, maybe start with a new database as I recommended above. I have not found such delays since this was addressed in 7.2.3x.

Before starting with a new database, I moved my existing database from my HD to the SSD (although there is not much space left on it). It is amazing, how much faster eM Client has become.

Yes, because a mechanical hard disk probably has no more than 300 operations per second, whereas an SSD has maybe 30,000.

renaming the em client folder in appdata seems to have resolved the issues I had

also my other problem I posted has vanished
 
https://forum.emclient.com/emclient/topics/adresses-which-are-not-blacklisted-but-still-in-junk-folder-some-kind-of-rule-issue

one negative thing:

somehow all my drafts got lost - although they should be on the IMAP server, which has nothing to do with reinstalling or deleting the em client folder before doing this (?)

another thing that emerged:

connection issues with my gmail account - eventually it downloaded the mails from the server, but still, most of the time, em client shows this 

for my other adress (GMX) the connection works fine, although the rule resp. spam folder issue I posted hereis still an issue (it vanished only for 1-2 days)

If the drafts were on the server, and they have disappeared, maybe a question for the provider. Even deleting folders from your database (though highly discouraged) should not affect what is on the server as the server always has precedence. The only time eM Client will delete from the server is if you delete the messages or folders yourself within the application. But in that instance they will be moved to the Trash folder

For the connection issue, if it works sometimes and others not, again maybe a question for the provider. But you can check the settings just to make sure.

SMTP should be port 587 and Force usage of SSL/TLS
IMAP should be port 993 and Use SSL/TLS on special port (legacy)

Sometimes a firewall or anti-virus application may block the connection, but then it usually is not an intermittent thing. It either does or it doesn’t. But if you continue to get the error, then maybe disabling those applications as a test could confirm.

Another possibility is that eM Client may be too sensitive to your Internet connection, and so assumes at times that there is none. You would have to look in Menu > Tools > Operations > Log tab to see if there is any further information on the error.

My experience is that GMX is a whole lot more stable than Gmail. Maybe because it is a vanilla IMAP server, or closer to one than GMail.

drafts

not really sure what went wrong. either I deleted them by accident (unlikely - nothing in the trash folder), or GMX messed this up, too

connection

thanks so much. indeed, it was the firewall from avast which caused the isse. so I simply deactivated that avast checks my mails, the GMX spam mechanism should be enough, I guess (?)