Version 5 will not install.

I cannot install version 5. It gets about 3/4 of the way done installing, and then I get an error message that states that setup.msi is not a valid installation package. Can anyone help?

Where did you download the installer from? Try to download it from here: http://www.emclient.com/dist/v5.0.180… and let me know if it helps.