Version 5.0.17595.0 crashing often

This version crashes less frequently than earlier versions, but still 5 or 6 times daily. Randomly. I click a folder, or an email, or a menu item, and it crashes. This is on a 1 year old windows 7 x64 machine with 6 Gigs of ram. Everything else is stable and working fine.

Is there anything I can send you to help identify the problem? Anything on my end that could be causing this? Version 4 never crashed, but I’ve had continuous problems with version 5 since upgrading.

Here is a screenshot of the error:

Here is partial text of the error log:
eM Client (5.0.17595.0)
Windows: Microsoft Windows NT 6.1.7601 Service Pack 1, Framework: 2.0.50727.5466
The following error has occurred:
System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
at System.Windows.Forms.UnsafeNativeMethods.CallWindowProc(IntPtr wndProc, IntPtr hWnd, Int32 msg, IntPtr wParam, IntPtr lParam)
at System.Windows.Forms.NativeWindow.DefWndProc(Message& m)
at System.Windows.Forms.WebBrowserBase.WebBrowserBaseNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(ApplicationContext context)
at MailClient.Program.b__3()
at MailClient.ExceptionUtils.ExceptionUtils.Filter(BodyDelegate body, FilterDelegate filter, Action`1 handler)

eM Client
5.0.17595.0

false

Microsoft Windows NT 6.1.7601 Service Pack 1
2.0.50727.5466

System.AccessViolationException
Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
System.Windows.Forms

System.Windows.Forms.dll
100664865
System.Windows.Forms
System.Windows.Forms.UnsafeNativeMethods
CallWindowProc

mscorlib
System.IntPtr
wndProc

mscorlib
System.IntPtr
hWnd

mscorlib
System.Int32
msg

mscorlib
System.IntPtr
wParam

mscorlib
System.IntPtr
lParam

ffffffff
0

System.Windows.Forms.dll
100669135
System.Windows.Forms
System.Windows.Forms.NativeWindow
DefWndProc

System.Windows.Forms
System.Windows.Forms.Message&
m

3e
92

System.Windows.Forms.dll
100688262
System.Windows.Forms
System.Windows.Forms.WebBrowserBase+WebBrowserBaseNativeWindow
WndProc

System.Windows.Forms
System.Windows.Forms.Message&
m

14
f

System.Windows.Forms.dll
100669134
System.Windows.Forms
System.Windows.Forms.NativeWindow
DebuggableCallback

mscorlib
System.IntPtr
hWnd

mscorlib
System.Int32
msg

mscorlib
System.IntPtr
wparam

mscorlib
System.IntPtr
lparam

25
56

Hello, this often happens if some libraries are not properly registered in InternetExplorer (we use IE core for displaying messages).
To see if the re-register of the libraries help, please go to http://iefaq.info/index.php?action=ar… and download the zip file according to your system configuration, extract it and run the file inside

Thanks. I have IE9 on Win7 x64.

I’m not experiencing any problems with IE on websites etc.

I ran the ie8-rereg.32on64.cmd script as the webpage says it works on IE9 as well. I did that this morning, but still had 4 crashes today.

Any other thoughts?

I’m having the same problem of eM crashing on my Win7 64-bit machine. I created a thread and question but noone has answered it yet. Mine happens when I click on an attachment…specifically a PDF. The entire program freezes. Everything else in Windows works fine but eM is in a frozen window. I have to go to task manager to shut it down. But after I do that it won’t start up again until I reboot the computer. I used to work in IT and keep a very clean machine and load of Win7. Oh also when this happens and I go to reboot the application running window appears saying something like “eM is un-initializing”. I have to force the reboot. This stinks and with no help from above.

I’m sorry to hear that it didn’t help. Other thing you could try is to reinstall Internet explorer, or to upgrade it to version 10 if you don’t mind. It often solves a lot of problems, even if you do not experience anything in the IE itself.

When it happens again, please run the tool available from http://www.emclient.com/tools/emstack… after the freeze happens. It should generate a log file (starting with “eM Client Stack” in your Documents folder) that will help us analyze the problem in more detail. Please send this file to us. Thanks.

[email protected]

I went ahead and installed IE10 and that did not make any difference either, still multiple crashes per day.

I collected some crash reports using the emstack tool that George directed me to above, and I will email those to him. Thanks.

Hello Sam,
we have checked the error reports received from you. They show that the core of the problem is indeed the one that should have been fixed by applying the script from http://iefaq.info/index.php?action=ar…

Please try running the script again - also make sure that you are launching the script as Administrator. To be sure, you can also run ie8-rereg.64on64.zip.

Best Regards,

Thank you Libor, I am pretty sure I ran it as Admin. But just to be sure, earlier this week I ran it again and made sure to be admin. Still having the problem. No issues with IE that I see, no other problems with anything else that I notice, just EmClient. I did notice a new version 5.01.79180 which I installed just now. Hopefully that will help. But so far the script above did not make any difference for me. Thanks.