v7 wiped out v6 data - all email and contacts are gone. are files overwritten or can they be recovered?

v7 wiped out all version 6 data including all settings, email, contacts - EVERYTHING.  I cannot find v6 files and I fear they have been over-written.  How can any software wipe out a prior version with no notice or opportunity to make a backup? (yes, I know, I should have backed up  - but - you’d think the install process would have a “heads-up” screen)    I tried to cancel out of “upgrade” and it proceeded anyway.     Perhaps I missed something after a long day, but I saw nothing that said MAJOR VERSION CHANGE coming - I assumed it was a maintenance update.
Any help appreciated

Don’t panic-- it didn’t wipe out your data.  The v7 upgrade leaves the version 6 data in tact, but the database requires an update.  You probably missed the prompt to import your old data, but that’s OK, you can still do it.  Simply go to menu/file/import and select “eM Client version 6”

I appreciate the reply, but I had tried that.    All data in the folders underneath C:\Users\cktg\AppData\Roaming\eM Client  has been wiped with NEW V7 data

it WIPED OUT version 6 data unless someone can tell me a different place to look

Did you not use the default location for the version 6 datafiles?  You may have to browse for them if not.

Or maybe the version you were using was too old.  What version were you using?  My suggestion is to uninstall version 7 and reinstall the version you were using.  Then upgrade to the current version 6 (Maybe just install a newer version of 6?  Might work). You can get older versions ere: http://emclient.com/release-history. the uninstall will NOT remove your data. Then upgrade to 7 and import.

version 6 data files were in the default location.   I was using version 6 - however, since the data files were apparently wiped out I have no idea what specific build I had - it was up to date as far as I knew.  I generally install updates - as I “thought” I was doing with this suicidal version.    I’m not clear what uninstalling v7 will do - uninstall will not bring back the file versions that were in place before version 7 (apparently) over wrote them - I appreciate your input, but I don’t see a way out of this mess

When you choose to import from version 6, you need to specify the source folder. In your screenshot, the directory location is empty, therefor nothing to import. 

Start the import again, then in Select source folder choose C:\Users[username]\AppData\Roaming\eM Client.

I appreciate the input, but in that directory are Version 7 files which overwrote the version 6 files.   I just did a cut of the path.  Using the full path, I get an error that “no version 6 files are found.”   All of the files in that folder have the same time and date, the time of the alleged “upgrade”.  Yes, clearly I should have backed up at some point. Regretfully, I didn’t.  But in 30 years of PC use, I’ve NEVER had an application overwrite data files without some kind of warning.

eM Client also does not delete the old files without prompting, so your 30 year streak is not broken.

After upgrading from 6 to 7, you would have automatically been prompted to convert the database. If you chose not to do that, the version 7 database would have been empty. The version 6 database will still have been intact in the same folder. Uninstalling version 7 and then installing version 6 will automatically use the old database again. Jay suggested you do that, but for some reason you do not want to do that.

If you chose to convert the database after the udate, you will also have been prompted to keep the old data or delete it after it was imported. It would not have automatically been deleted.

In all scenarios, eM Client does not delete anything without prompting. Even uninstalling the application does not delete the database.

Thank you for your response.   I was not reluctant to try the uninstall 7/reinstall 6 - I just wanted to investigate further, and I was just trying to be cautious since I didn’t want to do more damage.  HOWEVER, uninstalling 7 and re-installing 6 seems to have worked so I want to thank you and Jay for all your assistance.   THANK YOU

Jay, I want to sincerely thank you for your assistance.  Uninstalling 7 and re-installing 6 did the trick.

BTW, I tried to cancel out of the 7 installation and it “skipped” right to the end - so, some of the things you mentioned during installation I never saw - but that’s a moot point now.

Thank you again,

BTW, the path that I gave you above, you need to replace [username] with your own username. The best way is to browse to that location as pasting in the path I gave you in my comment above will not work. Hence no version 6 files found. You may also have to enable hidden items in Explorer before you do that.

By cancelling the installation, you skipped the conversion of the version 6 database, that is why when you opened version 7 it was empty. :wink:

import can only be done once. eM client somehow marks the old database and can no longer use it for import. (I don’t trying version 6 on this “marked” DB). I see same error as @Caroline. Now I’m dealing it with VIP support. As one of the problems …

I do this by restoring the original database from the backup files (to another folder) and importing it from here. Account by account, because I get error on end of all import (“module ObjectManager”).

Martin,First, the version 7 import process really sucked - when I tried to cancel out of it, that’s when the real problems started.
In any case - as the commenters here suggested - I UNINSTALLED version 7 and re-installed old/reliable version 6 and I got my data back. 

I have since made a full back up of my verions 6 data and will do so periodically so a rogue install like version 7 doesn’t cause this again.
Good luck.