Using contacts folder without gmail account

The question is quite straight: if I don’t have any Gmail account, can I still use the eMclient contacts managing section?

By now, I configured several business email accounts on a fully lifetime licensed version of eMclient; none of this accounts is a gmail account. The contacts section is empty: no contacts; no contacts folders; it’s not possible to create a new contacts folder and even if I manually create a new contact, it simply disappears when I save it, because there is no place where to save it (no contacts folder at all).

It really seems that without a gmail account eMclient is not able to handle contacts. Is this right?

Thanks for your support.

In the Contacts section of eM Client there is a Local Folders–>Contacts.

If you have Gmail contacts, go to that folder and select all of the contacts. Then right click and select Copy to Folder, selecting that Local Folders–>Contacts folder. 

This will create a duplicate of all Gmail contacts into the Local Calendar so you will always have them on hand.

If you have no Gmail Contacts, then just create your contacts in the Local Calendar folder and all should be well.

It seems ther is no escape from the gmail contacts. I have tried, in the Calendar section, to create a new contact folder, but really nothing happened. No folder, no error message, no confirmation message, nothing at all.

I have linked a gmail account and the gmail contacts seems to be correctly imported, even if it’s not possible to create new sub-folders via the eMclient and I have to do it directly on the gmail account. Also, it’s not possible to delete the default categories or label.

And also, I really can’t find anywhere a “Local Folder”. Only Gmail folders.

It really seems that the contacts managing system of eMclient is its weakest point…

What version are you using? I am running the second v7 beta and have both a Gmail and Local Folder section shown in the Contacts window.

What do you see in this same panel? It might be that this Local Folders option does not appear unless you actually have an email account in addition to Gmail.