Using column configuration when in compact layout doesn't work

When selecting ‘always use compact layout’ column configuration option doesn’t work.
Is this by design or is this a glitch because it works when using ‘always use single-line layout’.

In Compact layout you have 15 columns displayed, but in a different way to a single line layout.

To the left are Flag, Read status and Avatar. Then From, Subject and Preview one on top of another, etc. You can even change the order of these three so you have the first line the Subject rather than the sender.

Was there something specific you wanted to display, bearing in mind that some of them can’t be in a different position? Like you can’t replace the Avatar column with the Date column.

This is what I see…just 2 items.

This what is selected.

Well, you cut off the screenshot, so we can’t see anything. If you had shown the message in the list, you can see the following columns:

  1. Read Status
  2. Avatar
  3. From
  4. Subject
  5. Preview
  6. Flag
  7. Received
  8. Notes
  9. Snoozed

etc.

But as I said, they are not displayed the same way as they are in a single line layout.

I didn’t want to show personal info…


I selected all 21 available columns and this is all I see.
Why don’t I see the column headers below received and select. I see the date and time and tag and subject in the actual email but not on the header bar where usually you see the available columns like you do when you select always use single line layout.
This is what I’d like to see.

Because this is a compact layout and some are above others. Look at my screenshot above. Where would you put the column header for the Preview column for example? Where would you put the column header for the Notes column?

It is not possible to show the column headers as you would in a single line layout. The columns are still displayed, but the headers can’t be added in a multi-line layout.

It would be nice in the individual email header itself to see folder location when viewing tagged emails instead of having to click on properties as we previously discussed some time back… as well as a few other info items…
As always, thanks for the feedback Gary!