Upgraded to 7.2 -- "Mark messages as read after displaying for [0] seconds" no longer working.

First off, let me just say that I am thrilled  to be able to meet my e-correspondence needs with eM Client. It is by far the easiest, most comprehensive client I’ve used.

I did upgrade to 7.2 yesterday, and so far I’ve only noticed one issue. I always let the client mark messages as read after displaying for 0 seconds, but now they are not marking as read at all. Even if I click on the email to open and close it, it still doesn’t change the status to ‘read.’ The only way for me to do so is to right-click on the message and choose “Mark as Read.”

I am using a Windows PC. If there’s any other information you’d like me to provide, just let me know.


I’m having the same problem.

I’m seeing this too. Increasing the timeout to 1 second works as expected. Not ideal, but a workaround of sorts for now.

Same problem here. Very frustrating.

Hi all,

Thank you for reporting this bug. The mark as read set on 0 seconds was really broken in the new 7.2 release. We fixed it and it’s now part of the newest update available at: https://www.emclient.com/release-history.


This bug does look to be fixed now, thanks!

Note that running “Check for Updates” didn’t find the new version (I was on 7.2.33888.0, am now on 7.2.33974.0 after downloading and installing the update manually). For what it’s worth, I think the “Check for Updates” problem not finding new versions has been happening for a while, not sure if this is something you’re aware of or not?

eM Client pushes new versions out in waves so as to keep traffic on their servers steady and possibly catch bugs before they hit the masses.  Microsoft does the exact same thing for Windows, it’s common.