Upgrade is missing a file

Hello,
Trying to upgrade to the newest version. Aborts with the message that the file SETUP.MSI cannot be found.
Please send that file to me or a link where I can get it.
Looking forward to it,
with kind regards,
Piet de Geus
Netherlands

domingo 16 mayo 2021 :: 1232hrs (UTC +01:00)

Hi…

You can download from here:

https://www.emclient.com/dist/latest/setup.msi

¡Saludos desde la soleada España!

Skybat

emc_forum@compucall.com

1 Like

Hello Skybat,
Thanks for your cooperation, but this links downloads the original em-client upgrade and it is not the setup.msi hat is missing with me, as indicated by thy install-function of the upgrade.
regards,
Piet

The link that @skybat gave is the setup file. It is the same whether you are installing for the first time, or upgrading - there is no other file.

Gary,
But why does the installer then looks for a file "SETUP.MSI’? It is not on my system. Where can I find that fileamongst the many other setup-msi’s, which seems to be a frequently used name.
regards,
Piet de Geus

  1. Close and uninstall eM Client, making sure NOT to delete the database folder when asked. That will ensure all your data and settings are there later.

  2. If it exists, delete the C:\Program Files (x86)\eM Client folder.

  3. Download and install the latest version from here: https://www.emclient.com/dist/latest/setup.msi . After the download it will automatically be named emclient-v8.2.1237.msi

  4. Restart eM Client.

Gary,
Also the uninstall via Windows Settings\Apps\EmClient is asking for the same setup.msi, so even the uninstall is not working.
What to do now?Piet

lunes 17 mayo 2021 :: 1433hrs (UTC +01:00)

Hi Piet…

1./ What version of eMC is currently installed?
2./ Before trying to upgrade has eMC been working correctly?
3./ Have you been creating backups?
4./ If you have not created a backup do so: Menu -> Backup…
5./ Please tell me exactly what process you are doing to upgrade eMC
6./ What is the name of the file you have downloaded for the update?

¡Mis mejores deseos y mantente a salvo!

Skybat

emc_forum@compucall.com

Hi,
Still the same problem. As a result of the Google-warning for API I again tried to refresh EM Client on my laptop.
Still the same message that setup.msi was missing int the Tempfolder of AppData\Local.
After exporting mails and contacts I tried to uninstall EM-Client, as to try to have a clean new install. Unfortunately also the uninstall wanted to have the setup.msi file and stopped.Also saying it could not remove the old version although the entry in the Apps-setting was removed.
Then I removed manually everything I could find of EM Client, out of Programfiles and App-Data (2 locations).
Also then the new 8.2 would not install, same message.
Then I ran Regclean, in the list was EM Client still present, but clicking on it for removal caused Regclean to crash.
What else can I do re re-install EM-Client?
regards,

Piet de Geus
Netherlands

mine just installed fine. My guess is that your anti virus is interfering with the install process, quarantining the file before it can run.

You could restart Windows in Safe Mode, and try the uninstall that way.

If that is successful, restart Windows normally and install the latest version from the Release History

DMA2112,
That is what I already did earlier. It is not only that it cannot find that msi, but also the folder in which it should be according to the installer-message is not existing in my AppData.
Piet

Gary,
When in Safe-mode the installer says it cannot work in safe-mode, so that way`is also not good to go.
Piet

While in Safe Mode, open an elevated command prompt.

Copy and paste the commands below into the elevated command prompt one at a time, and press Enter after each command.

REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal\MSIServer" /VE /T REG_SZ /F /D "Service"

REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Network\MSIServer" /VE /T REG_SZ /F /D "Service"

net start msiserver

Close the elevated command prompt.

You should now be able to uninstall eM Client.

Gary,
Please instruct me on how to open an elevated command prompt. I see no such thing in Safe-mode,

And at the end: Is net=next? What then do I enter into the command-prompt? Just “msiserver” or “start msiserver”?

I still tried things, but in vain, so please react on my former question on how to set up such a command prompt and the instruction on what to do afterwards.
Regards,
Piet

  1. In Windows, click Start.
  2. In the search box, type cmd.
  3. Right-click Command Prompt app in the results and select Run as Administrator. If done properly, the User Account Control window opens.
  4. Click Yes to run the Windows Command Prompt as Administrator.

Gary,
Thanks for the instruction, I arrived in The command prompt with the line c’\my name\user
The I entered the first REG ADD Line from your example. It gave the message: Syntax error. as the examples given there-under did not show " before or after parts of the command, I entered the line again without ". The same result, syntax error.
What can we do now?
regards,
Piet