I am currently running eM Client version 5.0.18637.0

When I start the app, it tells me that there is a new version (58.0.18661.0). It downloads the update and the try’s to install but fails with the following error message.

I have found this to be because the update is expecting the MSI file in the temp directory to be named setup.msi but the downloaded MSI file is named tmpxxxx.tmp.msi where the xxxx is a random set of 4 alpha-numeric characters. It looks like you need the MSI installer to look for the MSI file under the downloaded name, instead of setup.msi

To get round this, I rename the downloaded MSI file to setup.msi and double click on this file it will run and asks to repair (which I gather is the update running in interactive mode instead of quiet mode) the installation. I allow it to repair the install which completes successfully, and it restarts the eM client but when I check the About under the help menu, it still shows the old version, so hasn’t updated.

I run the check for updates and the same thing happens again.

Can you advise how I can sort this problem?

I am running Windows 8 Pro 32bit, Version 6.2 (Build 9200).

Regards Ben


try using this file http://www.emclient.com/dist/v5.0.190…


Thanks, that appears to have worked.

Regards Ben

Hi, thank you for you information :slight_smile: