Unable to set up Google Apps account

Using eCm Client version 6.0.23421.0 downloaded today, running on Windows 10 Pro x64.

Trying to set up a Google Apps account but failing. The account has 2 step verification turned on, but as you will see below when I turned it off it still did not work. Here is what I did:

After initial installation, I started configuration. eM Client found my domain on the Gmail server and I went into the OAuth web session to authenticate. At this point, 2 step authentication was turned on. After entering my credentials I received the error message telling me JavaScript was not enabled in my browser and I could not complete authentication.

I read in the forums that 2 factor auth was the problem, so I turned it off for my account. Since the account was not set up, I exited eM Client and restarted. Again, I went to accounts and started the process. When I made it to the OAuth web window, I entered my credentials but I cannot get off that screen - no error message, just nothing at all happens when I click the button.

When I turn 2 factor auth back on, then I can get past the login screen but I can’t get past the JavaScript failure.

I can manually configure the settings for mail (it takes quite a bit of jumping through hoops, but eventually I can get mail working) but then I can’t get either contacts or calendar to sync because eM Client does not recognize the manually configured account as something connected to Google.

What do I need to do to connect to my Google Apps account? Turning off 2 factor auth seems to make it worse. So far nothing works yet the same account seems to work just fine with the Windows 10 email client.


Hi David,
the 2-step authorization was usually part of the problem for people who already enabled JavaScript in their browsers, but I see you didn’t mention if you have that.
So first I recommend checking if JavaScript is enabled in Internet Explorer (it need to be IE even if you use a different browser as a default one).

If Javascript indeed is enabled I recommend trying this solution provided by another user on this forum: https://forum.emclient.com/emclient/t…

Best regards,

It is already enabled. And that is also the default state. This seems to be a common problem for people since you moved to OAuth for Google (if the messages here are any indication), but in my case for a G-Apps account turning off 2 factor did not help. In fact, it made things worse.

Also, if you will notice, I already did that. I turned off 2 factor and tried it.

So, with the knowledge that JS is in fact enabled, where do I go next?

Hi David,
this is actually a common problem since 1 day ago and is now a known issue that we are trying to figure out.
We’re sorry for the inconvenience as we try to find solution to this change that must have happened somewhere on google’s servers.

Best regards,

Looks like I picked the wrong day to start evaluating…

(not snarky, just a modified quote from the movie Airplane)

Any update?  I am a little concerned that none of the other programs I am evaluating have this problem.  Seems like a basic issue and one that has been around at least a couple of weeks.  Any news would be helpful…

I’m also waiting on a solution. Shouldn’t have to lower my security to sign in.

I’d be OK lowering my security for the brief time it takes to configure the account.  Problem is, that doesn’t work, either.  ATM there is just no way to get this to work with my G-Apps account. 

I have two personalities, “real name” and “fake name”, I noticed that when I log in to my google account on Internet explorer, I know have to choose between one or the other now but I can’t remember to have seen that before. May this be a hint? Having an extra pop-up to choose your personality not being taken into account by em client?

If I had to guess, it is probably something related to the JavaScript and how eM uses a browser window.  With 2 factor auth enabled, I get the dreaded “JavaScript is not enabled” error when clicking the login button from the credentials screen, and that is coming from Google (so the browser control eM is using is not reporting to Google that it has JS capabilities, perhaps?). 

When I disable 2 factor, clicking the login button on the credentials screen does nothing.  Because I can’t get to a terminal window, I am continuing to guess but I would think eM is trying to intercept the onClick event to do something and there is a JavaScript error which is preventing Google from processing their part of the event.  

It also has to be something related to Google Apps and how they handle the credentials screen.  I tried this with a plain vanilla Gmail account.  Same issue with 2 factor, but once that was disabled the account setup worked as designed.  So Google must be doing something different for G-App accounts on that screen, and eM is horking that up with 2 factor turned off.

I just wish I could get some traction on figuring this out - a workaround or something other than “sit tight”.  

another possible workaround that worked for another user is to set IE 11 security level mode to medium and disabling protected mode in security tab.
But we still didn’t manage to find the real reason to this problem.


I’ve actually tried this with no change. Still get the same error.

Tried this as well, no change.

Also added Google to the trusted zones, again no change.

To recap: with 2 factor turned on with my G-Apps account, I get the “JavaScript not enabled” error message.  JavaScript is in fact enabled.  When 2 factor is turned off, I can’t get off the credentials screen - clicking the button does nothing.

If you look further below, I suggest some things regarding how you are processing JavaScript.  Not sure if any of that helps, but whatever you have going on it is clear that Google does not recognize JavaScript is enabled.

Same problem as David here. Google Apps account just doesn’t log in (with 2-step auth turned off).

Ok, i found a work around.

Open Internet Explorer and log in to mail.google.com with your Google Apps account.

Then go back to emClient and log in again. This time login window will work.

Nope. Doesn’t work on Windows 10 x64. I opened IE (not Edge), logged in and left the browser window open. Started eM Client and tried to add my account with 2 factor configured, and landed on the same “JavaScript is missing” page. Then I went back to the browser, removed 2 factor, shut IE down and restarted. Logged in to my account in IE, restarted eM, tried to set up the account - and stuck on the credentials screen because the login button does not work.

Still completely dead.

Same here — except I’m trying this on a non-Apps account (on a regular Gmail account) on Win10-64. None of the workarounds posted so far work. I still get the “Javascript is missing” error.

The error I get is that I need to upgrade to a modern browser. The ‘JavaScript missing’ error went away - I click on a continue button that appeared. But I can’t get past the requirement to upgrade to a modern browser.

I have the same issue. No resolve so far.

Actually the only client ive managed to get functioning with this is Outlook which works like a charm.

Any update? The main reason for my choosing eM Client was the fantastic integration with my Google Contacts, making it a kind of quite powerful personal CRM.

I’d just like to point out one phenomenon that I observed, may this be a hint… when I enter the code Google sends to my cellphone, it will be placed above, not at the right of the “G-” prefix.

This is where I end up then (same message as for everyone here):

Keeping fingers crossed for a fast resolution of this.