Unable to deselect "Make messages available offline"

Right click on Account - go to Offline Tab and the box to deselct Offline Sync is greyed out. I don’t want my messages synced.
Using 3 Office365 accounts.

Hi Ed, I’m not completely sure what you’re referring to, if you right click your account and select Properties > Offline, you should be able to setup the option “Download messages for offline use”, this option enables that all received emails are downloaded completely including the body of the message, without this option you’re only downloading headers of emails and the body and attachments are downloaded after you click on the message.

Can you please specify the issue you’re having or possibly make a screenshot of the issue?

Thank you,

Screenshot of the issue below - I am unable to untick the option so they’re not available offline - The client is always trying to sync (spinning circles next to each account) all the time, and so it takes a long time for email to send/come through as it’s busy syncing a folder list for another account!

Hi again Ed, what version of eM Client are you currently using and what mail service are you using with eM Client?

Thank you,

i have version 6.0.21040.0 and using 3 office365 accounts connected via MAPI Exchange - all 3 accounts behave in the same manner.

Hi again Ed, Exchange accounts synchronize all your data for offline use automatically, that’s why this option is greyed out.
You can only differentiate between downloading attachments automatically or manually for each message (the second option).

This is an intended behavior for Exchange accounts.

Thank you for understanding,

Can this be changed to only sync the last X days? either globally or per folder?

Hello, unfortunately this is not currently possible with eM Client.