Unable to add Outlook.Com account with 2FA

Hi,

I’m trying to connect emClient to an Outlook email address that has 2FA enabled.
I go through the emClient Add Account screens and enter the email address etc.
It goes to the 3rd screen and when I click Finish, it opens the Outlook login screen.
I enter my email address and password and am prompted to verify in the Authenticator app.
I verify the access in the Authenticator app and am prompted to allow emClient access to the account - which I accept.
From that point onwards - nothing really happens - emClient has a prompt saying that the operation can will take a while - that spins.

I then get a dialog that pops up stating that “Communication with the previous instance failed. The other instance has to be ended in order to start the application”.

If I cancel the password dialog, and then click the Finish button again, the webpage that opens up asks me if I’m trying to sign in to emClient. This at least tells me that emClient has already been approved and recognised by Outlook, but I’m still unable to access the emails etc.

Any ideas how to fix the issue here and allow me to access my email?

Thanx,
Alon

What version of Windows are you using?

Windows 10 x64 - with LOTS of RAM and all the Windows Updates installed

If you have enabled TLS 1.3 in Windows 10 that could be the cause, as it is not compatible with that version of the OS. If that is what you did, disable it, then try the account setup again.

I haven’t enabled TLS 1.3 specifically.
Can you please tell me where to check for this?

I’ve checked this link: How to enable or disable TLS 1.3 in Windows 10? - ASUSTOR Inc.
I do not have the TLS 1.3 registry entry

I’ve also checked the Internet Options in Control Panel - TLS 1.3 is not enabled

Then it could be an issue with the browser blocking the popup that would normally ask your permission to open eM Client.

So something like this (Google example but the same applies)

image

Maybe set a different browser as the default in your OS, and try the account setup again.

Thanx,
Will give it a try and see how it goes.
I currently have all browsers set to block popups, so will need to fiddle with that

Thanx for your help so far

I changed my default browser to Chrome and enabled pop-ups.
I tried to add the account again in emClient and received the pop-up in Chrome.
I ticked the checkbox and clicked the Open button.
Immediately afterwards I received the popup in emClient stating that “Communication with the previous instance failed. The other instance has to be ended in order to start the application”
I clicked on the Ok button and I’m back to waiting as before.
The Microsoft login dialog in Chrome also shows ‘busy’ with the dots running across the top of the dialog.

Any ideas?

If you have any optional Firewall / Security programs or optional Antivirus programs or VPNs, try completely disabling those to test incase any of those are interfering with it.

Also try default browser using Edge (Chromium). Reboot after changing browsers. Also clear your cache completely in your browser’s as well. Even try resetting your browser to defaults. Also try clearing your local temp OS files as well

Failing that “go online to your Outlook / Third party apps” and remove any old eM Client OAuth tokens.

Also in your Outlook online account, remove any old 2FA app passwords (if they are there too) and then close and reopen eM Client. That re-run the automatic email wizard setup again.