Trouble restoring from backup


Yesterday I did a clean install of Windows 10, reinstalled emClient v7 and now I can’t restore my backup. It just opens a dialog saying the selected folder does not contain any backup files.

I did do the misstake of installing emClient 8 first and I could restore from my backup file there. Since my license was only for v7 i uninstalled v8 and reinstalled v7 and it now I can’t restore the backup. Not even new backups made in v7 are recognized.

I have tried looking in the Manifest.xml file and installed that exact version (v7.2.40748) but that didn’t help. I have also tried boh higher and lower versions of v7 but with same problem.

I tried unpacking the backup-zip to see if it could find it then and I tried manually copying the files into AppData\Roaming\eM Client but no success there either.

What else can I do besides paying for the v7 to v8 upgrade (as v8 seems to work)?



One thing you can do, as you have a Pro License for version 7, is open a support ticket with eM Client asking for help about restoring to version 7. I am sure they will be able to help.

In the mean time there is something you can try.

Find the latest backup you made with version 7. Extract the zip file to some location on your hard disk, say C:\Downloads.

You said the xml said it was 7.2.40748. Uninstall eM Client from your computer and download and install that version from the Release History.

When eM Client starts, cancel any setup windows and go to Menu > Settings > General > Storage and click on the three dots. Select the folder where you extracted the backup zip. That is the folder that now contains the extracted manifest.xml file.

Restart eM Client.

If that works, close eM Client and move the extracted folder contents to ~AppData\Roaming\eM Client folder. Maybe delete the ~AppData\Roaming\eM Client folder contents first.

Restart eM Client and change the Storage to ~AppData\Roaming\eM Client and restart again.

Hope that makes sense.


Amazing Gary, the steps you described worked perfectly. Thank you so much.