To: column not displayed when searching sent items

When searching a sent items folder the To: column doesn’t get displayed. If I right click the column headings and go into the column configuration I can add it - but this setting doesn’t stick for next search.

This is with version 8.0.2685 (for Windows). I have a PC running version 7.2 (for Windows) and this version doesn’t show this misbehavior.