there is no "corporate option" when setting up sync2em

I am testing sync2em on an Android.

My phone is a Samsung Galaxy GT-5570

If you don’t have Corporate option there, please, try set up an Exchange account type.