. The problem i have is when creating new email messages

when I type /select the contact Name em changes this to be contact’s email address followed by contact’s email address
I would  like that to be Contact Name followed by contacts email address

It should be the name followed by the address.

Does this happen with all contacts? Can you maybe give a screenshot?

Sounds like the Email “Display as” field in the contact is set to the email address alone. It is being found through the full name and then is changing to the “Display as” information.

Change the "display as field to the name you want to appear and then enable the “Settings>Mail>Read>Show email address in header” and it will appear as:

 “Name” <name@email.com>