"The message will be downloaded next time you go online" - How do I fix this issue? My computer stays online.


Maybe you have by accident selected the option ‘work offline’ in the ‘File’ menu?

Did help from user Hans helped you? If not then do you see any error messages and what version of eM Client do you use?


I have also seen this problem, although it is temporary in nature. I believer it has occurred after the PC is waking up from sleep mode. I can get it to display properly by clicking on “Send and Receive” repeatedly, or by viewing another message and returning, or maybe just waiting.

Have you tried to use one of suggestions users before you proposed?


Hi, I have the same problems. An no Hans, I do not go into a menu and change an option by accident. Simply eM client says I am offline while I am really online. It helps if I switch “works offline” on and then off, but it remains a nuisance.
regards, Maarten

what email service provider and protocol do you use?


I use gmail.

and your protocol for receiving emails?

Anyway this is usually happening when server is disconnected from server while downloading message.

So as addition to my previous question tell me if you see any red " ! " sign near your account folder and if you have tried setting “Download messages for offline use” in case if you are using IMAP.


Hi Jan, I use IMAP. And yes, sometimes I have an interrupted internet connection (electricity is a bit choppy here). But when it comes back on, I can use web browsers no problem, but eM says there is no connection to the server. Tes, with a red! I have to click on “work offline”, then unclick that again.

so it is wrong connection, then I really suggest you using “Download messages for offline use” Under IMAP tab in account management.

It will help you when you will loose your connection even for a moments.


Please excuse me, but where do I find the option “Download messages for offline use”? I looked around, but can’t find it. I am using the Dutch language version. And some times I see a red exclamation mark.
best regards, Maarten


in Tools - accounts - your account - IMAP tab.

Yes, I found it. But when I set the Work Offline option, I get many instances of the flagged emails, instead of just one. I need these for my work flow, so thats not a good option for me.
regards, Maarten

Problem with flagged emails is know and we are trying to find solution for that.

But if we do not count this issue, was turning on “download messages for offline use” helpful?


I was having this issue with all of my email accounts.  I would usually be able to download the messages if I double clicked on them to open the email window or if I clicked off of that message and then back on.  My gmail account in particular was constantly giving my notices that it could not connect to the imap server. 

Found the issue to be my antivirus, Eset Smart Security 8 - Email client protection.  I turned this off and the emails are now coming through just fine. 

Hi John, thank you for sharing your solution, some security software can some times disable the applications ability to connect to the setup services, make sure the Ports you’re using for synchronization of your email and that you’re able to access Port 80 or http://licensing.emclient.com/ in case of any connectivity issues with our licensing server.

Thank you,