Synchronizing folder list failed with an error: The remote server returned an error: (500)

Using version: 6.0.21 I get these errors every retrieve email cycle on both gmail and an exchange account.  Both are on the get folder list operations.

Error message for gmail:

1:57:00 PM xxxxxxx@gmail.com [GData]  Synchronizing folder list
1:57:00 PM   MailExceptions.OperationException: Synchronizing folder list failed with an error: The remote server returned an error: (500) Internal Server Error. —> System.Net.WebException: The remote server returned an error: (500) Internal Server Error.
1:57:00 PM    at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
1:57:00 PM    at MailClient.Protocols.OfflineAddressBook.OabFolderSynchronizer.GetFolderList(Folder homeFolder, CancellationToken cancellationToken)
1:57:00 PM    at MailClient.Protocols.Common.FolderSynchronizer.<>c__DisplayClass5.b__0(WorkerStatus
status, CancellationToken cancellationToken)
1:57:00 PM at MailClient.Protocols.OfflineAddressBook.OabGenericCommand.Execute(WorkerStatus status)
1:57:00 PM — End of inner exception stack trace —
1:57:00 PM at MailClient.Protocols.OfflineAddressBook.OabGenericCommand.Execute(WorkerStatus status)
1:57:00 PM at MailClient.Commands.Command.Process(WorkerStatus status)
1:57:00 PM xxxxxxx@gmail.com [IMAP] Synchronizing subfolders: Done

Looks to be same error on exchange email as well.

-j.p.

Hi J.P. what version of eM Client are you exactly using, can you please check for the version number in Help > About?
Can you please try to update the application to this version http://www.emclient.com/dist/v6.0.21151/setup.msi and check if the issue persists?

Thank you,
Paul.

installed v6.0.21151 as requested.  Still have error.

Hi again, please try to navigate to your eM Client database folder in your local folder > App Data > Roaming > eM Client, and delete all the *.oab files located in this folder.
Reopen the application and check if the issue persists, however I’m afraid that if it does, I’m unable to help as the error clearly states this is a server issue.

Thank you for understanding,
Paul.

I am experiencing the same issue. The initial sync provided me with all folders in the account. If I make a new subfolder in my account through outllook, I see that it does not get synced to eM Client indeed, as the error suggests. The content of all existing folders gets synced correctly however.

I installed the above suggested update without success. The *.oab files suggested to be cleaned above do not seem to exist on my system.

We have a fairly new and standard implementation of Exchange 2010. Stating that it is a serverside problem just because eM Client’s error says so is a little bit too easy I think. eM Client claims exchange compatibility, not the other way around. I you need further info please inform me of what you need exactly.

Hi Con, the errors are thrown out based on a communication between the application and the server. It’s a protocol error, you can enable logging for the service and check the logs for errors, logs contain all the communication from the protocol service.

This error is connected to an Exchange account, maybe you’re experiencing another type of issue. Please submit your error log to the forum in order to resolve the issue.

Regards,
Paul.