Sychronize subfolders

How do I set eM to automatically sync subfolders within my inbox?

I have several subfolders within my Hotmail IMAP account Inbox that don’t sync until I actually click on the folder in the eM folder list. Until that point, the new message count is blank “…”, and it takes a minute when I click on it to load the messages. How do I tell eM client to do this automatically without my input?

Hello Rebecca, you can enable automatic synchronisation for the folders by enabling the option “Download messages for offline use”.

If you’d like to use this option on all your subfolders regarding this account, navigate to Tools > Accounts > Your account > IMAP (Mail) tab and enable the download messages for offline use option for your account. In case you’d like to enable this for certain folders only, please right click the folder in the left pane and navigate to the folder properties where you should be able to enable offline options as well.

Hope this helps,


This does only work if you set the synchronisation for example on 5 minutes? The realtime sync (push mail) only seems to work on the folder that is selected at that time. Is this correct? 

Hello Rob,
if you enabled synchronization in Settings it should actually work for all of your items, not just the folder you have selected.

Best regards,

So the realtime sync does only work on 1 single folder? You have to set the synchronisation to a certain time (in my case 1 minute), and Google seems to block the mutiple connections… Why doesn’t the realtime sync work for all folders?

No, synchronization works for all folders. If you are being blocked there might be some issue. Do you get any error pop-ups?

well, if I set the synchronisation off, and offline use on, then there is no error. But then there is no email in the subfolder untill I click on it. The selected folder gets its realtime sync without issue.

if I set the synchornisation on to 2 minutes, and also offline use on, then I get mutiple connection errors.

Please copy the content of the “Operations > Log” window for me so I can take a look at the errors.

ok, I will set the sync to 2 minutes and wait for an error and come back.

thanks in advance :slight_smile: