Stop auto-expanding Inbox mails sorted by Received

So my Inbox is Sorted by Received and I have compressed the items in the inbox.

Now the problem is that if I select the Sent folder or any other folder and come back to my Inbox , all the items (Today, Yesterday, Monday) are auto-expanded and I have to compress them again ( my preferences aren’t getting saved ). I don’t want them to auto-expand because only “Today” messages are important to me instead I’mpushed to see all the mails from Yesterday, Monday etc. 

Is there already an option to set a preference for this, or if not can you add this as a preference or fix the bug directly.