Sounds are off in settings but there is still a sound for incoming mail

I do not want sound alerts for incoming mail. All of them are turned off. But when I get a new email, eM makes a disruptive sound. How do I ensure that no sound is made when all of my settings are set to silent already?

Some sound issues were fixed in yesterday’s release. You can download it at http://www.emclient.com/release-history and see if that makes a difference.