Snooze sync across devices not working

I run eM Client on my laptop and desktop. If I snooze a message on one, it does not sync on the other machine. Makes no difference which way I do it. It is obviously doing it locally, but honestly, that is worthless. Is there a work-around for this or some setting I may have missed? Thanks in advance.

eM C. V. 8.0.3385
Windows 10 latest build on both machines.

Yes, that is a local function only, the same as when you snooze event reminders.

The IceWarp Client has some other sync options that are not there in the vanilla eM Client, but I don’t think that version syncs snoozes either.

Thank you for the response Gary. The IceWarp Client would be a lot of functionality that I do not require. Hoping someone might have a work-around to re-map to the outlook IMAP snooze folder. Think that is the correct way of explaining myself.

Checking back on this.

Anyone know if this is in the pipeline or has anyone found a workaround?