SMTP fails

I’m trying to get my local email set up on eM Client. I have tried several solutions, but can’t get the SMTP fixed. I can receive messages, but not send. 
When I set up the account using the automatic set up, the IMAP sets up fine, but there are no tabs for outgoing under the settings. When I open a new message, the From says “no account.”
When I try to set it up manually, again, the incoming server is good, but the SMTP fails. The fix in the Test Configuration isn’t fixing it. 
I previously had this account to forward to my gmail, but I turned that off. 

I am using version 6.0.24928.0. It tells me there are no updates. 
Any other ideas? 

Suggest you visit the web site of your email provider and review its instructions on how to set up email clients. Most will have instructions for Outlook and others from which you can copy the proper settings for servers and authentication protocols.

Thank you, IsoQuantic. I did do that. It still did not work correctly. 

What email service provider are you using?

Charter. Here is the link for setup:

When I get to the outgoing server step, I have tried it both with checking the box and not for requiring authentication. Then in the test configuration step, the SMTP shows “fail.” I click the fix button, but that also fails. If I ignore the results, I can get email. If I try to send a message, I get an error: SMTP server doesn’t support authentication

Are you following the precise instructions for the Desktop setup at that page for IMAP protocols?