SMTP Authorization Issues.

Recently switched my provider back from GMail to my ISP.

The Pop is working perfectly, the SMTP is not.

The user name/password for Pop and SMTP are identical.

When I attempt to “fix” via the accounts window, it will connect, say server requires authorization, which I send, and then it says my credentials are rejected.

I >>THINK<< it’s trying to log in with my full email address rather than just my user name. Or at least, when I say “sure, I’ll try entering my info on my own” it has the Username field filled as @.

Did you change the Acct SMTP Server address and Outgoing port back to how it was before ? Also did you have SMTP Authentication before with eg: SSL enabled & port 465 and Username & Password ? Or did you use Old school POP SMTP Server Port 25 with No authentication ?.

Thanks for the super quick reply …

Admin told me : 587 - Authentication on. STARTTLS if it’s an option or SSL/TLS.

… further playing around has shown it’s trying to send my email address from the “User Information” as my SMTP log in rather than just the user name I’m telling it.

Yes both will send via secure connections. Port 587 is preferred by some ISP’s as it checks emails on the way out for spam etc. Gmail uses that too. You would normally use in that case eg: “Force usage of SSL/TLS” in the Security policy (under port) in EMClient acct SMTP Setup. If you have a domain account, you would also use your “Full Email address” & Password.

Ps If the Force use of SSL/TLS doesn’t send, then try the other Secure options in the dropdown.

Also anytime you change SMTP settings, move or delete any previous failed sent emails (from the outbox) into the drafts folder and then close EMClient and then reopen and resend the draft emails. Prev stuck emails in the outbox would still have the old SMTP Server settings in them & may not send again due to the old settings. Best to do that until you get email sending ok.

The update from my server admin :

The error message is an incredibly helpful “(recv): Error in the pull function”

I think what it’s complaining about is that you are trying to authenticate over a non-encrypted session. It looks like it’s trying to establish a TLS (encrypted) session, but is failing.

I did a complete clean reinstall. Had my admin on VNC and basically it seems to be getting stuck on TLS negotiation. I’ve tried all the security policies with an open / close of the program between them.

Anyone have any brilliant ideas? :frowning:

The security policies are specific to the ports, and so are usually not interchangeable. Having different combinations may result in rejected credentials, even though the credentials are correct.

Port 587 = Force usage of SSL/TLS
Port 25 = Use SSL/TLS if available
Port 465 = Use SSL/TLS on special port (legacy)

The username is generally the email address of the account, so use that unless the provider (who you did not name) specifically says to use something else.

Mystery SOLVED!

“For [ahem’s] sake. The mail server software doesn’t use the standard passwd file for authentication. The only user I’d added was mine. I’ve now added yours with the same password and I successfully sent a message.”

Thank you everyone for your suggestions and support. Super, duper appreciated!

I will also be making fun of my admin for the next several weeks.