Maximum time incoming server is not in order so my incoming mails are not coming. When I go to Mail and diagnose  there also it says that incoming server not working 
mails are going very slow

You did not say who your email provider is. That might help in determining the problem.

But some things you can check:

  1. Go to Menu > Tools > Accounts and click on the IMAP for your account. Make sure the port is set to 993 and the security policy is Use SSL/TLS on special port (legacy)

  2. Temporarily disable your anti-virus/firewall application  and see if there is any difference.