Server says "(AUTH) Authentication failed" is msg when sending emails

Win 10
An error occurred.
“SMTP doesn’t support authentication”

Select another security policy in the account settings.

I tried all combinations of security policy. But, no change. When i tried “force use…” I got an additional error of incorrect settings.

Have you double-checked the required SMTP settings on your Mail Host site?

Yes. Comcast does not give specific instructions for settings for EM but does for other clients. For those most suggest using port 465 while one or two suggest port 587. I have tried both without success in correcting my problem.

I am a comcast/xfinity user.
For out going mail the server name should be:
The recommended port : 587 (SMTP)
only if needed: 465 (SMTPS)
SSL encryption should be checked (ie on)

Maybe this will help. I do know that when I tried to activate emclient to xfinity inside a corporate firewall a few years ago (so I could get my personal emails easily while at work, not to use emclient for work) , the firewall blocked a number of ports which included blocking comcast send ports.