Sent mail not showing in Sent folder.

I do not see any sent items in my Sent folder.  I did review similar questions and replies on this site but so far nothing has worked.    Here’s the particulars.

  1. I am using Gmail, under Tools>Accounts>IMAP, I have “Automatically detect special folder names” checked, with “[Gmail]/Sent Mail” in the “Sent:” folder name.
  2. I can run diagnostics for IMAP and SMTP and they work fine (i.e. I do send/receive a test email).
  3. Sent items do appear in my online Gmail account.
  4. Under Tools>Settings>Mail>Send> I have "Save a copy of Sent messages in “Sent” folder checked.
  5. This is on a Windows 10 machine.
    Any thoughts appreciated, and thank you for your time.

-> tom

NEVER MIND.  I can see my “Sent” emails, under my “Gmail” account folder.  I had that minimized and wrongly focused on expecting sent items to appear in a “Local” folder.  This is good enough for me!

Thanks anyway!