Sending emails takes a long time

I wrote an email and assumed 10 minutes later it was already sent. I tried to close emClient but got an answer: “There are messages to be send, do you really want to close emClient?” But there are no emails in the “To send” directory. I let emClient “work” and after a 10-15 minutes the Message was send and I could close the app.

Hi, can you go to Tools > Settings > Mail > Send, and check if “Send messages immediately” option is checked, if so, is the application showing an activity (bottom task bar, shows sending messages or similar?).
Is the message sent when you click on “Send and Receive”?

Thank you,
Paul.

Hi Paul,

yes, the option “Send immediately” was checked.
The application shows activity in the Status Bar :

“Syncing Directory …A”
“Syncing Directory …B”

I have a lot of them :=)

If I click Send and Receive there is no msgbox or similar.

Only when trying to cancel the application there is a message “There are messages not sent .:”

There are 3 messages right now in the queue but where is the queue? Can I see the messages not sent yet anywhere ?
Roman

Do you have smart folders visible, if not can you go to Tools > Settings > General and check “Show Smart folders”, save the settings, and right click the smart folders in the left sidebar and display outbox smart folder.

Let me know if there are any items in this folder when you have issues with this.
Thank you,
Paul.

OK, now I see local folders, my Outbox, I see my emails …
I pressed “send all” … but emClient does not care about this, it is syncing other folders instead …

Sometimes it send immediately after clicking “Send all”, but not very often.

Roman

Hi, can you please go to Tools > Settings > Advanced and turn on SMTP logging for the problematic account, save the settings and restart the application, when the issue occurs again, please go back to the advanced settings window and click on “Send Logs”.

Please send the logs to my email address, [email protected] and please add a reference link to this forum topic.

Thank you,
Paul.

…and turn on SMTP logging for the problematic account, …
There is no option SMTP Logging, I see Network communication only, this should be the right one ?
Roman

There has to be SMTP option, it’s not under general, but under your account in the list.

Thank you,
Paul.

Oh, I have a Connection to Exchange Server, the only option under my account is Exchange Webservices only. I do not use SMTP.

Oh, sorry my mistake, for some reason i thought you’re using a different mail service. In this case what version of Exchange are you using? And what version of eM client are you currently running?

Thank you,
Paul.

Hi Paul, do you have a solution?
Roman

Hi, no I don’t, can you please answer my questions that I asked above?

Thank you,
Paul.

Exchange 2010,
6.0.20154.0
Roman

Can you please try to download this version and update your app (http://www.emclient.com/dist/v6.0.20224/setup.msi), let me know if you can see an improvement… Unfortunately with Exchange all the folders have to be synchronized so it might take a bit longer than with other services, how long does it take now before the message is sent?

Thank you,
Paul.

Hi Paul,
I can not see an improvement.
The Message is staying in the Outbobox folder, you can click on “Send all…” Nothing happens. emClient is syncing folders …
A fast reply to am mail is not possible.

Roman

Can you please go to Tools > Settings > Advanced and turn on Exchange Web Services logging? Save the settings and restart the application, when you do so please right click your account and select Properties > Repair and click on the Repair button, try to send out an email and when you do so go back to the advanced settings window and click on Send Logs, please send the logs to my email [email protected]

And please add a reference link to this forum topic (URL).

Thank you,
Paul.