Send / Draft doesn't show emails if the eMClient is offline

If eMClient is OFFLINE, the emails I send are not shown anywhere.
So if I’m offline and I send email and I change my mind not to send email, I can’t delete it.
Usually in other clients this kind of emails would be in “Draft” until email wouldn’t be send.
What can I do?

Hi Andrew or anybody who happens to come across this problem.

I know it’s an old post and probably resolved, but since there’s no answer,
Here’s a way to show the “Sent”  (actually pending)  mail.

Under  Menu - Tools - Settings - General -General , tick either Smart Folders or Local Folders
or both and you’ll find the pending message there in Outbox

So you can delete it there at will…