save copy of sent messages for POP and IMAP

The “save copy of sent messages” option should be linked to each account rather than a global setting, since for an IMAP account this gives duplicates, whereas unchecking it gives no saved copy for POP accounts.  This can be overcome using a Rule for the POP account to make a copy, but this is not obvious to a new user.

I have the same problem.
And is not related to POP only.
Some IMAP servers I use doesn’t automatically copy sent emails. Other do. So I end to have duplicate sent emails or non at all.

Please mode the option to per account basis.