Rules not working (repost)

I’ve posted this before, but I can’t find a response, or the original post.  I have tried several different options but so far not a single rule works.  Also, going through the rules posts it reads that once one has created a rule it cannot be applied retrospectively.  I would like to be able to create a rule that moves all mail from, say @example.com  to local folders\tech\example_com "On receive, "On send, and manually started  by apply rule.

I’m rapidly drowning in unfiled emails. Please help.  Good, strong filtering is key for power users of email products.

Hello Ali,
sorry about not addressing this issue; I remember it, but I seem to not be able to track it either. I remember the rules set up looked correct though, so I won’t ask to see it again.
Instead, I’d like you to go to Tools>Settings>Advanced and check the option for Rules logging.
Restart eM Client and then try to run the rules (either manually try to apply all or send a test email that would trigger the rules).
If the rules are not applied, go back to the Advanced settings and click the ‘Send logs…’ button, but change the recipient to rust@emclient.com with a link to this forum topic.

Regards,
Olivia

Olivia, I’ll give it a day or so, but after I rebooted and ran the rules, it seemed to have worked.  I think it’s messing with me.  So can we give it a couple of days before we close the issue and I’ll leave the log running.  However, for some reason, after I rebooted em client had changed the location of the log files.  

Hello Ali,
the logs are always located in your database folder in a separate Logs folder.

Regards,
Olivia

It was pointing to  s:\em client\logs
It is now pointing to: C:\Users\ali\AppData\Roaming\eM Client\Logs 
The database/storage location is: S:\eM Client\

Did you change the location of your database before or just now?

I set the location of the database (and logs) immediately after installing.
I checked the location of the logs before I rebooted (when I ticked logging).
After I rebooted I checked the settings again, and the location had changed.