Rules do not work reliably or in combination with each other.

I have eight rules defined, and each of them works properly when I invoke them manually with the Apply rule button. However, they either do not work at all or work intermittently when they are invoked automatically. There is never an instance when all of the rules have been appropriately applied to several incoming messages that they should have acted on unless I invoke the rules manually, which makes the entire Rule function worthless. :frowning:

I have tried putting the rules in different orders in the list and I’ve experimented with the available options within the rules, but nothing I’ve been able to do has made the rules function the way they’re supposed to.

Rules worked great in Outlook Express! Why can’t you just duplicate that functionality instead of reinventing it? The result of your rule implementation is very, very bad.

Hi, are you trying to use your rules on emails that has been received after you have read them on other device?

Jan

Since I’ve got the same problem, I’ll answer the question: yes. But it shouldn’t matter. I read email on 3 devices, and if they won’t interoperate, then eM Client is not the program for me. Pity.

Hi,
unfortunately rules only apply when new emails are received. If you read the emails on a different device and then open eM Client the rules won’t be applied. That’s usually a standard feature, for example Thunderbird works the same way. You can of course create the same rules on all your devices that you’re using to get the same email behavior.

I’m sorry if this is an issue for you, maybe if you’d like to see an improvement in this area, make an  “Idea” topic and let other users vote on improving the feature.
And we might improve it in future releases.

Thank you for understanding,
Paul.

I gave up on eMClient a month or so ago, so I haven’t checked in here since then until today. I’m using Spamihilator to catch the spam that the filters on the mail servers let through (I have four active email accounts on four different servers). Unfortunately, the way you’ve implemented your rules (“rules only apply when new emails are received”), eMClient assumes all incoming mail has been read, since Spamihilator opens it to check it for spam. This renders your rule function absolutely worthless. Whoever made the decision to limit rule functionality in this manner ought to be fired. This limitation is pointless and serves no purpose whatsoever. This and a few other poor design decisions make eMClient very frustrating to use.

My favorite email client for many years has been Outlook Express, and the only reason I tried eMClient is the upcoming end of support for Windows XP. Outlook Express is many times better than eMClient in many ways, but most importantly, it’s rules work exactly the way you’d expect them to and are completely reliable and trouble-free. Maybe if you guys wake up and consider what your users want and need in an email client, make the necessary changes, and implement all the things that are missing, I’ll give eMClient another try. The way it is now, it’s inadequate, and it’s just not acceptable.

Hi, I’m sorry you feel that way.

We are listening to user’s suggestions all the time, if you’d like to see these features improved you can maybe make an Idea topic so we might add it in future releases if the user feedback is sufficient.

Thank you for understanding,
Paul.

He’s just told you what he wants. Why does *he* have to go and make an “idea topic” or whatever you want to call it.?? He’s just told you what he wants. He’s told you his way! NOT in the way *you* want him to do it. This is exactly what he is saying about your setup.
Just listen to him!
Why don’t *you* make a note of his “idea” ?

In this day and age of smartphones, tablets, separate computers at home and work, your architecture, and Thunderbird’s for that matter, is antiquated.

And while I don’t care for the tone of the two previous comments ( I’m fighting a lonely battle for civility on the internet), I agree completely with the content of their posts.

You have a pretty good product. I really want to like it.

Hi, I’m really sorry this is troubling you. I’ll pass the idea to improve our Rules settings to developers, and we’ll see what we can do about it.

Thank you for using eM Client,
Paul.

eM Client was recently recommended to me by a Fruux employee as being natively compatible with their DAV protocols for my calendars, contacts and tasks. I decided to test it as a potential replacement for Thunderbird (which is a real memory hog) and Outlook 2010 (faster & lighter, but lacking some major features I depend on in Thunderbird).

I’m about 99.95% happy with eM Client so far. The biggest problem I’m having is the same as the previous posters - the rules simply don’t work, either automatically or manually. It seems to be a major and ongoing complaint, from what I’ve seen on these forums.

I was planning to buy a lifetime license, but I can’t imagine paying $99.95 USD for an email client with non-working rules. I have too much mail to deal with from several different accounts to spend all my time manually dragging things around to various folders.

I’m still within my free 30-day trial period, and if no progress is made, I’ll have to just go back to Thunderbird and deal with its huge appetite for memory. It’s really a shame, because I feel that overall, eM Client combines all the best features of both Outlook and Thunderbird, and in a much cleaner and more customizable interface.

Hi, I’m sorry you’re having issues with this… Are you having issues with imported rules from Thunderbird or newly created rules in eM Client.

What exactly is the issue are the rules not automatically applying when receiving new email? Are you by any chance reading the emails first on a different device, this might be an issue since Rules only apply to new emails marked as unread…

Thank you,
Paul.

When I first set up eM Client, I imported everything from Thunderbird. Only a few of my many rules actually imported, and they didn’t work at all. After a small learning curve and some account problems, I had everything working and syncing properly.

I deleted all the imported rules, and set up new ones, but they refuse to work no matter what I try.

And no, I made sure there are no other devices reading the mail. The emails arrive in my inbox marked as unread. The rules won’t work, either automatically or manually.

What you don’t seem to be able to understand is that rules automatically applying only when mail has never been opened prior to being received by eMClient is a design defect. For many, if not all, of your users, this poorly designed functionality makes the rule function unusable. For example, as I explained earlier in this thread, I have four active email accounts on four different mail servers (one at my domain host, and one each at Google, Yahoo, and AT&T), and the spam filters on all of these servers do not catch enough of the spam for me to be able to run any mail client locally without also running a local spam filter (currently Spamihilator). Since Spamihilator, and most every other spam filter, intercepts incoming mail before it gets to eMClient, the rules do not function, because eMClient sees the mail as previously opened. This leaves users in the unfortunate circumstance of having to choose between functioning rules and spam filtering. There is no way to have both.

As far as your users are concerned, having the rules apply only to new emails marked as unread is a massive bug. Unfortunately, since you designed it to work that way, it’s not really a bug, and you don’t seem to be willing to change the way it works, even though it causes a lot of problems for many of your users. As I said, it’s a major design defect, and you need to acknowledge that and fix it ASAP.

As of early this morning, my rules have started working (although inconsistently).

The automatic rules worked briefly on all incoming mail, then only on some of it.

When selecting a folder for manual rule application, I had been simply checking the box for the main account folder, and then checking “include subfolders”. The rule didn’t work that way.

Then I tried checking the box for the main account folder, and then also checking the box next to “Inbox” for that account. The rule then worked when I applied it. It hasn’t worked every time, but the other way didn’t work at all.

I also have a question RE: proper formatting of domains in rule setup.

I like to set up my rules so that all mail from “domain.com” is filtered into a certain folder. I find that much simpler than having to enter a long list of individual email addresses.

Should the domain be formatted as “@domain.com” or simply “domain.com”? In Thunderbird, my filters worked with “domain.com”, but I’m unsure if eM Client requires a different format. It’s hard to determine this when none of the rules are consistently applied.

If you enable “Rules” logging in the menu Tools - Settings - Advanced, try to simulate the inconsistent rules behaviour and send us the logs for analysis that will help us to get a better picture of what is happening on your side because we don’t experience any issues with Rules on our side. Thank you. 

With some more experimenting, my earlier question (which apparently no one noticed) has been answered:

Should the domain be formatted as “@domain.com” or simply “domain.com”? In Thunderbird, my filters worked with “domain.com”, but I’m unsure if eM Client requires a different format. It’s hard to determine this when none of the rules are consistently applied.

It seems using the “@domain.com” format solves my problem. I redid all my rules using this format, and now they work properly and consistently.

In case it makes a difference, I’m running eM Client 6.0.20154.0 on Windows 7 Pro, Service Pack 1.

I forgot to mention this in my last post:

If the mail is coming from “subdomain.domain.com”, the sub-domain must be included when you add it to a rule, and you must use the format “@subdomain.domain.com” (if you want to add only a domain, and not a specific email address).

Hi, sorry, yes you have to use @domain.com etc. with the Rules settings, did you have an issue with imported rules from Thunderbird?

Glad it works for you now, let me know if you have any other issues or questions about the application.

Thank you,
Paul.

I had 2 issues with importing filters from Thunderbird:

  1. Not all of them imported

  2. Thunderbird’s filters can use the plain “domain.com” format, but eM Client requires the “@domain.com” format. I wasn’t aware of this when I first imported from Thunderbird, and assumed they would work in the same way.

In any case, the problem has been solved for me, so everything is working as it should :slight_smile:

Hi, thank you for this output, we might not be able to solve the issue number 1, since we’re not currently supporting all Thunderbird rules, we might be able to fix the issue number two for other users, using this.

Again, thank you for pointing this out and I’m glad everything works for you at the moment,
Paul.