Rule: "Where 'To' field contains" or anything which allows me to filter on the mail to field

Every time I get asked for an email address I make one up.  For example, a website called “Trouserman” (which sells trousers; not relevant, sorry!) asks me for my email address so they can send me news about trousers.

I give them this email address:  trouserman_only_feb_2020@mydomain.com

Trouserman send me a couple of emails which I delete because I already have plenty of trousers and I ask them to unsubscribe me. 

But a disgruntled Trouserman employee has copied the entire email address database and sold it to a disreputable mailing list business, who in turn have sold it to a boilerhouse operation in Nigeria.

Now I start getting emails about my “inheritance” which I can claim by getting in touch with an “accountant” who will liberate the funds.  The emails are addressed to…  trouserman_only_feb_2020@mydomain.com

I know it’s phishing of course.

But then I get one from Paypal asking me to follow a link.  It looks exactly like a real Paypal email.  But it is addressed to…trouserman etc

This has been a really good way of identifying fake emails.  It has happened with netflix_only_feb_ etc etc, french_holidays_only  etc etc   when they have lost data through theft or hacks.

Now to the point of this:   To get rid of these unwanted emails I would create (in Thunderbird) a message filter:  IF envelope-to is            or IF envelope to contains      send to spam

I can’t see a way of operating on the “mail-to” part of the message header in eM

Can anyone help please?

Thank you,

Andy  (brand new user)

PS there isn’t really a Trouserman site,  I don’t think.

Create a new custom Rule on messages you receive. Then you want to use the “with words found in the header” option.

Click on the words link in the preview and enter To: trouserman_only_feb_2020@mydomain.com, then Add.

Thank you, Gary, but even though I follow your instructions exactly it isn’t working.  Even if I establish the rule then invoke it and say “Run” on the root account it doesn’t do anything at all.  Could there be another setting which is preventing it working?

@Andy22

Gary even though I follow your instructions exactly it isn’t working.

Suggestion If your mail server has spam filtering options like alot of good mail server mailboxes do, try doing that same filtering online which then normally won’t appear in eM Client inbox.