Rule doesn't work...

I have a daily email that is always in my SPAM folder.  I have made sure its not in the blacklist and I have created a Rule to move it to my inbox upon receipt.  I have also added the email address to my contacts.  I can’t seem to figure out how to get this to stop going to my SPAM.  Anyone have any thoughts?

Hello Douglas,
rules in eM Client only apply to messages in Inbox, so once the message is in SPAM the rule will not apply automatically.
Check the SPAM rule options on your mail server.

Regards,
Olivia